1

Two days after upgrading to Catalina, I have noticed that some subdirectories are missing. I'm not exactly sure when these directories went missing as I was on vacation, but here is what happened.

  1. I upgraded to Catalina few days ago
  2. Decided to delete some directories, mostly node_modules from old projects, to get some free space.
  3. After that I didn't touch anything and discovered that some directories are missing when I get back home.

enter image description here

Original size of www directory was somewhere around 55GB and similar size is shown in Finder. DaisyDisk also shows that there are 55GB of hidden files somewhere (it's not telling where).

sudo du -sh www/ shows directory size of 10MB.

Free space before deleting node_modules was 11GB and after deleting (now) is 20GB. If files under my www directory were really deleted, free space would be much larger.

Based on other answers found here and on the Internet, I have tried the following:

  • Tried restore using DiskDrill. No success.
  • Run First Aid under Disk Utility. No success.
  • Relocated Items directory is empty. No success.
  • Recovering using Stellar Data Recovery. No success.
  • Scanned using GrandPerspective. No success.

What else can I try?

  • Do you have TimeMachine local snapshots and/or actual backups? You don’t need to have a backup drive connected for snapshots to be taken and they persist a while when you don’t have the drive attached. They show up as hidden space precisely where Daisy Disk has shown you – bmike Dec 5 '19 at 1:14
  • 1
    Where was the www directory? In your home folder, or somewhere else? – Gordon Davisson Dec 5 '19 at 1:28
  • @bmike I have backup from two months ago. Learned my lesson with this. On the positive side, most of my code is hosted on GitHub and I can restore from there. However there are still some data that will be lost if I don't restore them. – RhymeGuy Dec 5 '19 at 1:41
  • @GordonDavisson Yes, www is under mine home directory. – RhymeGuy Dec 5 '19 at 1:42
  • "there are 55GB of hidden files somewhere". Try downloading GrandPerspective, mount the .dmg and run as root with sudo /bin/launchctl asuser 0 /Volumes/GrandPerspective\ 2.2.3/GrandPerspective.app/Contents/MacOS/GrandPerspective. Select your whole volume to scan and this will show any hidden files. You can ignore the error about iCloud as root doesn't have an account. I found GrandPerspective wouldn't run as root without launchctl and DiskInventoryX wouldn't run at all on Catalina. – lx07 Dec 5 '19 at 7:37
1

There is a 3rd party app called Stellar Data Recovery. There is a free trial period that can be used to recover your files. I used it about 8 months ago for some lost files and it recovered them for me. It was relatively easy to use as I did it myself and I'm not great at that type of thing. The software sells for $80 but it has a free download.

  • I'm stuck in a loop with this one. It asks me to select volume for scan, then to enter password. After that it says decrypting and it refresh list of volumes asking me to select volume again... Edit: I will turn off FileVault and try again. – RhymeGuy Dec 5 '19 at 2:24
  • Removed FileVault and was able to scan. There are no files that I'm looking for. – RhymeGuy Dec 5 '19 at 12:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .