0

In a mac (10.14.6) I want to set the default application to files of type 'err' (i.e. files like test.err or output.err) to be TextEdit.

For that I follow the description given here, and set the default application to be TextEdit.

image

However, when I double click on that exact same file in the finder, I see the following text box:

enter image description here

So what am I missing? Why does it nor work?

2

I don't know why the existing two methods are not working - they both should.

Alternatively try RCDefaultApp which as far as I'm aware still works in Catalina. [I can only test up to Mojave.]

I added this manually using the + button & it actually suggested TextEdit itself. I'd suggest also checking 'Override file creator' & see if that might help.

enter image description here

| improve this answer | |
  • yes that seems to work just fine. Thanks – Alex Dec 10 '19 at 13:12
-1

The simple process goes as:

Right click on .err file and press Option , then Open with will change to Always open with.

Then select the appropriate application you want to open. It will open and then close it. Test it by double-clicking and then it should work without any issue.

Reference for it as a screenshot:

enter image description here

| improve this answer | |
  • Thanks - so the page I found is incorrect. I see – Alex Dec 3 '19 at 16:15
  • Did you manage to resolve it? If then would you be kind to accept the answer too :) – Udhy Dec 3 '19 at 16:22
  • No it still does not work. When I download a different 'err' file, the mac asks me again – Alex Dec 3 '19 at 16:25
  • It does not work. Sometimes it does. Strange behavior. But well, its a mac. – Alex Dec 3 '19 at 16:27
  • Maybe when I open the exact same file it does work, but if I select a different file with an '.err' ending, I am asked again. But not sure – Alex Dec 3 '19 at 16:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .