0

2012 Mac Mini, still running High Sierra (10.13.6)

Has suddenly stopped reading SDHC cards (even showing the card is available). Things I've tried:

  • relaunch Finder (via right click) - occasionally required previously, and has always worked
  • wiping the card contacts
  • rebooting macOS
  • disconnecting the Mac Mini and cleaning the rear SHDC slot (with slim bit of plastic)
  • verifying the card works elsewhere (Macbook Air)
  • testing with a brand new card
  • connecting an 8-in-1 card reader via USB and putting the card in that
  • checked Finder's display external disks setting was set correctly

Nothing obvious in Console log. Disk Utility shows nothing. No card in /Volumes on terminal.

Any suggestions?

Edit: ~ 24 hours later it has started working again. (At this stage I think I still suspect something physical to do with the slot, as I was getting intermittent results with the external reader today until I tried a second one...) I'll add I've found ejecting cards can often take ages, but not consistently (and even when the contents are not being browsed in Finder).

  • Are the cards formatted? If so, how? i.e. FAT32, ext4, NTFS etc – Seamus Dec 3 at 19:13
  • @Seamus I mostly use FAT32 (because of the format the camera uses), but I just reformatted the new one as macOS Journaled on the Macbook Air and it still isn't recognised by the Mini. – William Turrell Dec 3 at 19:24

You must log in to answer this question.

Browse other questions tagged .