4

I recently updated my MacBook Air OS to Catalina V 10.15.1 and since have issues screen sharing via Teams.

  1. When I try to share my screen I get an error prompting me to go to my "Security & Privacy settings"

enter image description here

  1. Clicking on the "Security & Privacy settings" button opens "Settings > Security & Privacy > Screen Recording" - see below. I've given Teams access to "Screen Record" as with Chrome and QuickTime (no issues with these apps). I've restarted teams and the computer several times - same result.

enter image description here

Is there something I'm missing?

1
  • Doesn't answer the question but I ended up just using the web version of Teams rather than the Mac app.
    – vladiim
    Commented Dec 9, 2019 at 23:52

4 Answers 4

2

The fix for this can be simple as entering the command:

tccutil reset ScreenCapture com.microsoft.teams

This will reset the permissions for the Teams app. More details here: https://silviustroe.com/cant-share-screen-microsoft-teams-fix/

1
  • For people having the same issue other applications, you can find the bundle identifier with osascript -e 'id of app "App Name"'
    – Richard
    Commented Mar 21, 2022 at 4:29
3

There is a strange workaround for this. Screen recording will work fine if you are in full screen mode.

The issue arises when you are in windowed mode or you have an external monitor connected.

1

I had the same issue, and I resolved it by giving PowerPoint screen recording access, too. My advice is to check which other Microsoft applications are in that list, and see whether or not they need access.

EDIT: After having another look at your screenshot: maybe you need to start PowerPoint before it appears in this list. Not sure about that.

1

I've also had this issue on macOS 10.15. I've found that if I attempt to share my screen in a scheduled meeting before or after the meeting is scheduled to begin/end I receive the We need permission to.... error.

However, during the scheduled time of the meeting it behaves normally. I also don't seem to have this issue when I'm joining an ad-hoc meeting (not scheduled within the calendar).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .