I am having trouble enabling /bin/bash on Catalina - Macos 10.15.1

When I try to enable it using "System Preferences -> Security & Privacy -> Full Disk Access", the pop-up finder list doesn't show /bin/bash.

As you can see from this screenshot:

enter image description here

The permissions on bash seem OK:

ls -l /bin/bash -r-xr-xr-x 1 root wheel 623344 Oct 24 02:34 /bin/bash

  • 1
    OK - I've found a solution... I used 'go to folder' in Finder to find /bin/bash, which I then copied to "System Preferences -> Security & Privacy -> Full Disk Access" - by dragging it with three fingers.... I hope there's an easier solution. – Peter Brooks Dec 1 '19 at 11:05
  • 2
    Can you explain exactly what you're trying to do? Why does bash need 'enabling'? If you're trying to get Full Disk Access, you need to give that to Terminal.app, not bash. – benwiggy Dec 1 '19 at 11:21
  • I'm using bash in a cron job. I found zsh broke (it doesn't have 'tempfile', as a builtin, for example), and bash failed with error 2. Now I've given bash Full Disk Access, my cron job is working perfectly. – Peter Brooks Dec 1 '19 at 15:17

The screenshot shows the content of /usr/bin, not of /bin :-)

  • Yes, you're absolutely right - thank you! Silly me.. So, now my problem is how to get to /bin - in bash, it's /private/bin - but I can't find /private with finder. I've tried: chflags nohidden /private -- but get: chflags: /private: Operation not permitted – Peter Brooks Dec 1 '19 at 10:59

I followed Peter Brooks' suggestion and it worked for me:

  1. system Preferences -> Security & Privacy -> Privacy -> Full Disk Access
  2. Click the lock in the lower left corner to allow changes
  3. Separately, Open a finder window
  4. "go to folder" /bin
  5. Drag /bin/bash to the Full Disk Access (right hand side)


When I Just clicked the + in the Full Disk Access thing, i could not find /bin/bash . It somehow wasn't visible. ¯\_(ツ)_/¯

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .