1

Macos will connect to my headphones for the first time and use AAC. On further connections, it will switch to SBC and the quality is beyond terrible.
The only solution I have found is to 'forget' the headphones in question and then reconnect them, as a brand new connection pairing brings the quality back to AAC.
I have double-checked with Bluetooth Explorer that my options are correct and also checked with other headphones. It happens on both pair.
I suspect that it has to do with the headphone microphone, but have had no real permanent luck trying apple's vague advice to quit offending applications and switch sources etc, advice I found here.

Does anyone know a permanent fix to stop the continual audio codec downgrade?

I'm not sure what version of OS X this began on, but it has been several months now at a minimum. I am currently running 10.15.1 on a 2017 touchbar macbook pro.

  • Microphone on perhaps? apple.stackexchange.com/questions/375995/… – bmike Nov 30 '19 at 23:31
  • Maybe? I have chrome on with microphone disabled (from chrome preferences) and no other apps running. – begs-the-hessian Nov 30 '19 at 23:36
  • Update: I've returned that pair of headphones. My current headphones simply have to be disconnected (and not forgotten) in order to regain aac. Luckily this is much less time consuming to do, but still frustrating. – begs-the-hessian Jan 13 at 11:45

You must log in to answer this question.

Browse other questions tagged .