0

I have an APFS encrypted 1TB SSD that I pulled from my now-dead MacBook Pro. I placed the drive into a USB dock and can mount it fine after entering the disk password. I cannot, however, take an image of this drive from Disk Utility.

When I select the volume, the New Image -> from "macOS" on the menu bar is grayed out. As I understand it, this is normal for APFS volumes; you can only create images of APFS containers or physical disks. When I select either the container or the disk, I can select New Image -> From [container or disk], but when I give it a file name and hit Save, all it does is tell me "Operation canceled."

I tried unmounting the volume first but got the same results. I also tried to hit New Image -> From folder and selected /Volumes/macOS. Then it gave me the error "Operation not permitted."

Thinking this was an issue with Catalina, I booted into Mojave and tried the same thing. This time, Disk Utility created the image as expected, but when I try to open the it, I get an error "Disk image couldn't be opened. Reason: No mountable file systems."

How can I take an image of this drive? Bearing in mind, I do not want to use 3rd-party software. This is something that can be handled natively for non-APFS disks, and I don't see why it shouldn't work for APFS containers.

Oh, and one more thing:
First aid reports no errors with the volume. I can read and write files to it just fine. I just want an archival snapshot so I can re-purpose this SSD. Thanks.

You must log in to answer this question.

Browse other questions tagged .