I have started to get some error messages about items failing to sync. It seems to be a sporadic issue - and the error pictured below was for a sync attached to the USB cable. I do have WiFi sync enabled for this device and it also happens when I'm syncing wirelessly, so the presence or absence of the cable seems to be unrelated to the error.

enter image description here

Opening iTunes on iOS doesn't seem to tell me what failed. The same goes for iTunes on my Mac. Does anyone have a clue where "more information" is logged in this case? Although many are suggesting ways to eliminate the error (trial and error), I'm more interested in where the error log lies. It baffles me there isn't some debug more or way to hook into iTunes to get a log of the problems.

Where else can I look for this information relating to sync errors?

  • Anything logged in Console? – user10355 Jan 19 '12 at 18:18
  • Just the normal _AMDDeviceAttached and Detached messages. I'll keep an eye out for the next time it happens. This time was busy with Xcode running, an iPad connected getting an iBooks Author document so maybe it was a USB timing barf... – bmike Jan 19 '12 at 18:32
  • Typically when something can't transfer, a dialogue box pops up in iTunes showing the items that didn't sync. I don't know if things have changed with the syncing over wifi. iTunes doesn't itself keep logs. If it does log anything, that goes to the typical log files that can be accessed through Console. But the error looks to be iTunes related (some part of your apps' documents or an app itself) and not iCloud related. – user10355 Jan 19 '12 at 21:43
  • There is no dialog on the mac when this happens which is what has me scratching my head - no dialog, no console log that makes any sense to me. I think the usbmuxd process is the intermediary and loosing the message somehow. – bmike Jan 20 '12 at 2:44
  • I'd say try to initiate the sync through iTunes and connected via cable. It should happen regardless if there's a conflict somewhere. It would at least narrow it down. I know wifi sync is pretty flakey... though I've never had a problem like this. Sorry, best I can do. – user10355 Jan 20 '12 at 4:02

I had the error again this morning - three items failed to sync.

I do finally have a potential culprit. The presence of App store updates seems to correlate with these errors. It fits all the criteria so far that come to mind.

  • temporary and sporadic (most of the time, I'm not in the process of downloading apps while syncing and even with simultaneous downloads, my internet is such that this is generally a 1-10 second window or less per app)
  • resolves itself without needing user intervention

I've poked at this several times and it doesn't seem to correlate with the sync errors in a pattern that I can detect.

The only explanation I can guess is that there is no log where these errors are collected.


Leave your device plugged into the computer. There should be a little alert icon next to the device name in iTunes. Click on that to see what the actual problems were. Information from: See iTunes for more information

In my experience, updating my apps and re-syncking has cleared the warnings.

  • This is the correct answer – Oliver Dec 2 '14 at 0:44

If there's an error log I don't know where it is, but I can suggest some things to look for in your iTunes Library:

  • Videos encoded in a format that won't work on the iPhone. (This might also be caused by a video podcast encoded in an incompatible format).
  • .psd (Photoshop Document) files (in your photo library)
  • Purchased media or apps registered to an Apple ID for which the iOS device isn't authorized.

Happy hunting.

  • I should have mentioned - the errors are sporadic and do not happen each and every sync. They appear to be equally prevalent whether I sync over WiFi or USB (and the majority of the time, it's an USB sync for my phone) – bmike Jan 19 '12 at 18:27
  • …which doesn't rule out the podcasts, but I presume you took that into account with your comment. If you immediately do another sync (after getting the error) does the error persist? – jaberg Jan 19 '12 at 18:35
  • No - the error doesn't persist, so I'm fairly certain it's not simply one bad media file that will error no matter how many times I attempt to sync it. Those types of errors are easy since you get a pop up window telling you at least the first such incompatible podcast. Here there is no dialog or error being shown. – bmike Jan 24 '12 at 13:38

The last couple of times that this happened to me (also syncing via USB) I wasn't able to find anything in the console or logs... The I noticed that there was little room let in my device, so before syncing again I removed some data (a couple apps), then tried the sync again and it worked fine with no warnings at all.

  • Hmm - I get the sync errors even with more than a gigabyte of free space on my phone. – bmike Aug 10 '12 at 14:32
  • But perhaps it's trying to sync an app that's more than a gigabyte... – daviewales Dec 4 '12 at 6:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .