0

In my external keyboard only, the tilde/backtick key produces section/plus-minus symbols. On the internal keyboard, they work fine. (Hebrew/English keyboards).

This problem has been discussed 1 2. However, the solutions do not work. I tried re-recognizing the keyboard in Settings and defining mappings in Karabiner as in the screenshot below, but these do not fix the problem.

T

  • Did you try the Ukelele solution?? – Tom Gewecke Nov 26 '19 at 15:20
  • 1
    What does pressing the topmost leftmost key produce? – Tom Gewecke Nov 26 '19 at 18:37
  • Ha! The section/plus-minus key produces tilde/backticks! So, though it will require some muscle-memory, we can consider this solved. @TomGewecke please compose an answer so I can accept it. – Joshua Fox Nov 27 '19 at 7:35
  • it would be nice to map tilde/backslash to section/plus-minus and vice versa in Karabiner, but section/plus-minus is not in the list of keys offered there. Do you know how to do this ? (I could try Ukelele to see if there is an option there, but I have Karabiner set up and would rather not mess around too much.) – Joshua Fox Nov 27 '19 at 8:55
1

You can probably find backpack/tilde on the topmost leftmost key instead of where you expect it.

Here is a custom layout made with Ukelele which may put it back where you want it.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .