2

I start to think this might be a bug in Catalina.

STEPS TO REPRODUCE:

  1. I formatted my Mac-mini to factory reset (don't remember if was High Sierra or Mojave)
  2. I created a user at first startup.
  3. I upgraded to Catalina
  4. After Catalina installation I create a few users admin and non
  5. With a new admin user I can delete other admin or standard users without problem but I cannot delete the user created previously to Catalina. The message says:

to delete the user you need to enter their password

I did it several time, is the password I still use it to login with that user and it won't delete the account.

(See the problem when I try to delete the 4th user: no options is prompted)

enter image description here

So there must have been some sort of change between OS version and users created after Catalina cannot manage users created before Catalina.

I also tried to change the password for the user, the problem persists.

I also tried to remove the user through Terminal, no joy:

sudo dscl . -delete /Users/"yourusername"

returns:

<main> delete status: eDSPermissionError

<dscl_cmd> DS Error: -14120 (eDSPermissionError)
  • If your Mac mini isn't encrypted (and if you have a proper backup) I would use the sledgehammer: Directory Utilities and sudo rm the /Users/bestsmile folder (which deletes all bestsmile data!). – klanomath Nov 26 '19 at 13:37
  • Tried, it doesn't work. I will add this to the post with relative error, thank you @klanomath – Francesco Mantovani Nov 26 '19 at 13:43
  • 1
    If Directory Util doesn't work: boot to recovery mode and use dscl to remove the user (similar to the T2-chip howto in apple.stackexchange.com/a/373103/93229 but instead of adding a password for root (= enable root) remove user bestsmile) – klanomath Nov 26 '19 at 13:48
  • @klanomath, that was not an option for me because we use EFI password and I cannot boot in Recovery Mode. But thank you anyway. Other people might like your suggestion. (But I cannot check if that worked) – Francesco Mantovani Nov 28 '19 at 9:40
3

I found the solution!

This was a user I created after the factory reset and therefore was created on High Sierra.

macOS High Sierra has a bug around the user 501 which is the very first user you create after login:

https://medium.com/@ambroselittle/cant-delete-original-admin-user-on-macos-high-sierra-1d79fb438246

https://discussions.apple.com/thread/8087348

So what we are going to do now is substitute the user you want to keep with the user 501 that you want to delete. Is a bit hacky but it worked on my Catalina:

  1. System Preferences > Login Options > Join… > Open Directory Utility…
  2. Click to unlock it. (You may need to Enable Root User in Edit menu.)
  3. Go to Directory Editor. Search to find the user you can’t delete — the original user that was logged in when upgrading to High Sierra.
  4. Find the GeneratedUID field on the right and copy it somewhere safe.
  5. Change one digit in it and Save.
  6. Find your new/main user account > GeneratedUID, paste in the one copied above. Save.
  7. Run diskutil apfs updatePreboot / in Terminal.
  8. Reboot.
  9. Login as your main user. You should be able to delete the original user now.

Strange that the upgrade to Catalina is not backward compatible and doesn't fix the issue related to previous users.

|improve this answer|||||
0

Choose don’t change the home folder when you delete the users. (One of the three options you didn’t select when preparing to remove the user).

Once that is done, it’s easy to clean up the files or sort out whatever permission issue was blocking taking ownership of the home folders.

|improve this answer|||||
  • Sorry @bmike, I don't get it. See the GIF, the only problem is with the last user when the system asks for "to delete the user you need to enter their password". It doesn't even ask for the home folder to be deleted – Francesco Mantovani Nov 26 '19 at 13:29
  • Hmm, the pop-up with the three options doesn't appear for the only user he wants to remove: Bestsmile – klanomath Nov 26 '19 at 13:29
  • Thank you @klanomath, and that user is the only that was created before upgrade to Catalina. I don't know how to contact Apple Devs but I thing it's something they need to fix. What do you think? – Francesco Mantovani Nov 26 '19 at 13:39
  • @FrancescoMantovani It can't be the only pre-Catalina user: bestsmile would be admin then (or you downgraded him later to a standard user) – klanomath Nov 26 '19 at 13:42
  • It was Admin indeed, I then tried to lower it as standard and it didn't worked neither. Tried to remove from terminal with sudo and admin user. Tried to change password. Nothing. – Francesco Mantovani Nov 26 '19 at 13:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .