1

Upon opening Pages, Keynote or Numbers I'm informed that it "needs to download the font X" with a skip or a download button via a dialog (great choice, something that remains in the centre of the screen regardless of which app is focused). It's just one font, it's perhaps 10 or 15 that reappear in a loop. I need to go beyond 80 clicks to clear them, even if I quit the app. Choosing download or skip makes no difference, the fonts are never installed, I don't know if they're even downloaded.

I've tried opening Font Book to download them there but when I click the download button I see a download meter appear and disappear in a flash. The font is never installed. They are all in the list of Mojave downloadable fonts.

I use a standard user account most of the time, so I logged in to my admin account and lo and behold, those 3 apps are marked for update. I ran the update, all 3 downloaded, not one updated.

I'd like to be able to get some work done instead of wondering how to track down and berate the developer that doesn't know not to test installs with elevated privileges, let alone for not making them work, so if you're feeling charitable (to me or that dev), any help will be much appreciated.

MacOS v10.14.6

iWork apps are:

  • Pages v8.2.1
  • Numbers v6.2.1
  • Keynote v9.2.1

I got those version numbers from the GetInfo mechanism, there's no way I'm opening the apps up again.

  • Did you try installing the fonts while being logged in as an admin user? No promises it will work, but it's at least worth a try. Also, what happens if you run the applications from your Admin user? – nohillside Nov 25 '19 at 9:25
  • I assume you have been able to use Pages etc. in the past? Which significant system changes (updates, restores, crashes) happened since you last used it successfully? – nohillside Nov 25 '19 at 9:25
  • @nohillside I did try and install them as the admin user, the download meter stayed for longer, still the fonts weren't installed. The apps won't even open as admin user, maybe because I ran the update. The problem started after I received a spreadsheet with Japanese in parts of it, so now the prompts for Japanese fonts come up. I already have the language as an input method in Keyboards. Maybe the last OS point update occurred since the last use but I don't think so, I'm 90% sure I've used something from iWork since. – Iain Nov 25 '19 at 10:50
1

I managed to fix this, I hope this helps anyone else facing a similar problem.

1. Installing the fonts.

Font Book v9.0

Greyed out fonts that need to be installed have a "Download" button but if you look at the information there's a download link in there. I found that by copying and pasting it somewhere else the URL had a double slash "//" which was probably interfering with the ability to download it. It's actually a link to fonts in the /System directory.

I found most of the fonts I needed here:

/System/Library/Frameworks/ApplicationServices.framework/Frameworks/ATS.framework/Support/FontSubsets

By right clicking the font name and using the "Add Fonts…" dialog I could browse to the font and install them.

2. Permissions

The apps still didn't work. One of the Numbers crash reports said that /Applications/Numbers.app/Contents/SharedSupport/DocumentResources/Metadata.plist couldn't be accessed. When I checked all the permissions were screwed up - some folders were owned by root, others had permissions that locked out anyone but the owner. So:

sudo chmod -R g+rwx "/Applications/Pages.app/Contents/"
sudo chmod -R g+rwx "/Applications/Numbers.app/Contents/"
sudo chmod -R g+rwx "/Applications/Keynote.app/Contents/"

and chown commands across the right dirs seems to have fixed that.

Can't say I'm impressed with this turn of events, the standards at Apple really have been slipping badly of late.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .