4

TL;DR I formatted an USB drive on my AndroidTV which failed, and am now trying to fix it from my Mac. Right now I can see the drive in diskutil list but it neither shows up in Finder nor in Disk Util. How can I reformat the drive so I can access it again?


So I've had this Samsung Bar 64GB flash drive, bought online. I'm a design guy, and I've seen the packaging, it looks pretty neat and legit to me. But can't confirm if this is really manufactured by Samsung.

Follow me along and please bear with me with this quite long story of how we got here. The flash drive is once working tonight, and now it can't be both detected and shown on Finder and Disk Utility app, but when listed on Terminal on diskutil list, it still does shows. Please follow along if I did anything stupid on any of these actions, and is there any way I could recover/re-erase my flash drive again. This is quite expensive and I don't want to buy another again any time soon. I want this to be an educational and lesson to me again on Pros and Cons of formatting disks on Mac, and what I should and shouldn't do, I'm mostly a Windows guy all my life, and I'm new to Mac and I am still unfamiliar on some things so maybe that's also part of it.

So my intention is, to watch movies on that flash drive, but for some reasons, the format I choose when I formatted it on my Mac, first time plugging in is exFAT, the thing is our Android TV box doesn't support that so I tried formatting it there:

  • But since it's just a low level computer, for some reasons when I switched inputs on HDMI, it looks like while formatting that 64GB flash drive (for that big, I thought it'll be longer than usual) it forced stopped, so I ended up with unreadable flash drive on Android.

  • Plugged it in on Mac, it still can be shown and read on Disk Utility and Finder, I formatted it into MS-DOS (FAT), I assume it actually format it as FAT32, as it says that's the most universal file system, Android, Mac and Windows supports. It finished, but when moving back files to it, it is incredibly noticeably slow, that at some point it got stuck copying just a 200MB file, I figured maybe it's because of the buffer files from the previous exFAT format, so figured out that I should do deep format, so on Erase on Disk Utility > Advanced Options > I amped the settings to the 7 pass.

  • The problem is suddenly, the power went out, but this Mac is already old. This is 2011 MacBook Air running Catalina, and got very fragile battery. While the electricity is out, I figured it'll never finish on this pace, and I'll run out of battery on this very fragile Mac battery, also this Mac always throttles performance because of the fragile battery so I figured, it'll not finish anyways without being plugged in, so rather than ran out of battery, I'll just force quit the 7 pass Erase on Disk Utility. I did it.

  • For some reasons, I can still access the drive on the Finder, and I tried copying back that 200MB file again, it got stucked again so forced quit the copying again

  • and power went back, checked and replug it again, this time it can't be shown on the Finder and the GUI Disk Utility app, but when you run diskutil list on Terminal, it still shows

Last login: Sun Nov 24 21:13:24 on console

The default interactive shell is now zsh.
To update your account to use zsh, please run `chsh -s /bin/zsh`.
For more details, please visit https://support.apple.com/kb/HT208050.
Steves-MacBook-Air:~ steven$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *251.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         250.8 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +250.8 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Mac - Data              70.5 GB    disk1s1
   2:                APFS Volume Preboot                 24.7 MB    disk1s2
   3:                APFS Volume Recovery                711.9 MB   disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4
   5:                APFS Volume Mac                     10.9 GB    disk1s5

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *63.5 GB    disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:       Microsoft Basic Data SMSNG 64GB              63.2 GB    disk2s2

See the last part, I think I messed it up that I did two failed erase, that Mac tried to reformat, make new volume of 63 GB when the total capacity of the flash drive, is basically just 64GB. And I even did it, two failed attempts at two different file system, 1 from exFAT, I think 2 times on MS-DOS FAT. The one is kinda successful fastest format, the other is the 7 pass format that I forced stop (btw I did that by Quitting Terminal or using Activity Monitor "Force Stop")

This is what it shows when I diskutil info disk2

Steves-MacBook-Air:~ steven$ diskutil info disk2
   Device Identifier:         disk2
   Device Node:               /dev/disk2
   Whole:                     Yes
   Part of Whole:             disk2
   Device / Media Name:       Mass Storage

   Volume Name:               Not applicable (no file system)
   Mounted:                   Not applicable (no file system)
   File System:               None

   Content (IOContent):       GUID_partition_scheme
   OS Can Be Installed:       No
   Media Type:                Generic
   Protocol:                  USB
   SMART Status:              Not Supported

   Disk Size:                 63.5 GB (63454533632 Bytes) (exactly 123934636 512-Byte-Units)
   Device Block Size:         512 Bytes

   Read-Only Media:           No
   Read-Only Volume:          Not applicable (no file system)

   Device Location:           External
   Removable Media:           Removable
   Media Removal:             Software-Activated

   Solid State:               Info not available
   Virtual:                   No

But it clearly says on just diskutil info that it's still 64GB and is on FAT file system now.

This is what it shows when diskutil verifyDisk disk2

Steves-MacBook-Air:~ steven$ diskutil verifyDisk /dev/disk2
Started partition map verification on disk2
Checking prerequisites
[  \   \   \   \   \   \   \   \   \   \   \   \   \   \  ] 

It's just stucked like that, and won't respond.

This is what it shows when diskutil repairDisk disk2

Steves-MacBook-Air:~ steven$ diskutil verifyDisk /dev/disk2
Started partition map verification on disk2
Checking prerequisites
[  \   \   \   \   \   \   \   \   \   \   \   \   \   \  ] 

To those that are saying I should be patient, I got a smaller 16GB flash drive here, and tried the same thing, it just works instantaneously, no more "Checking prerequisites"

This is what it shows when diskutil zeroDisk disk2

Steves-MacBook-Air:~ steven$ diskutil zeroDisk disk2
Started erase on disk2
[ \   \   \   \   \   \   \   \   \   \   \   \   \   \   ] 

Should I keep waiting it like that? Or no hopes and it's already stuck like that forever?

Please help me reformat, erased and make my 64GB flash drive usable again to be formatted correctly and completely on any file system. I don't want to buy an expensive and big flash drive again because I did something wrong here. Is it still recoverable or this is no hope now and I destroyed it? What things did I did wrong, and what should I prevent doing in the future, did I effed up all the way? Or is it maybe just the flash drive is faulty and I should return it?

Please any advice or help would be incredibly appreciated

3

Your intuition is a bit off - that's what gives you most of the troubles. After you have formatted the drive there is nothing left over - i.e. you do not have to worry about "buffer files from exfat" - cannot happen.

Similarly the diskutil listing is in no way any indication of "earlier attempts" or parts of a "7-pass format" - doesn't exist, cannot happen. There's absolutely no need for doing a 7-pass wipe either - it won't help anything at all compared to a single wipe. The big part you seem to be missing is that the drive is both partioned and formatted:

To explain: those two are not the same thing. It is very common for USB pen-drives to be just "formatted" - i.e. there's no partition table on it. This makes it easy to handle for low-level software like for example something you might use on an Android TV. In addition, your partition table is a relatively new kind of partitioning table - namely a GUID partition table (GPT). Some older or low-level stuff might only support an older type of table, knows as an MBR (Master Boot Record). Lastly, such a device might not support multiple partitions on the same USB pen drive, as you have.

My advise to you is to either (a) not have a partition table at all, and format the whole drive as FAT32 - or (b) create an MBR partition table with a single partition formatted as FAT32. Note that FAT32 has a limitation on file size, which means that you cannot store files larger than approx. 4 GB. If you want to store larger files, you'll have to divide them up. ExFAT doesn't have this limitation, but you indication that your box doesn't support it.

The first option (a) can be accomplished by first erasing the disk (as you indicate you have already done), and then running the following command in the Terminal:

sudo newfs_msdos -F 32 -v MYDISK /dev/disk2

You can do the latter option (b) by running the following command in the Terminal:

sudo diskutil eraseDisk FAT32 MYDISK MBRFormat /dev/disk2

BEWARE: It is very important to check that your USB pen drive is in fact disk2 before you run any of these commands!

| improve this answer | |
0

I consider all flash storage like USB/SD to be suspect and slower speeds, so you might need to let the zero run for hours. That being said, You don’t need anything more fancy than Disk Utility to erase an SD card on macos. Your diskutil commands also are fine to erase things when the hardware is working. You also did nothing wrong with your commands to use the product - I would have tested the same as you.

I would try one last time using Disk Utility - perhaps looking over the log for any errors while you erase it.

I use a tool to check SD cards as they tend to fail at a high rate for me and occasionally I’ll buy some that should be good and are not. The counterfeits are quite excellent from time to time and even the best of the best can fail.

The logical conclusion when you fail to verify the full size of the disk is it’s either counterfeit (only has 8 GB of space but was sold as 64) or has failed and you can seek warranty replacement / exchange from the vendor if you are covered by consumer protections.

| improve this answer | |
  • The question does not mention SD cards at all. – jksoegaard Nov 24 '19 at 23:02
  • I consider all flash storage to be SD, I’ll edit my answer so it’s clear. Your answer is awesome BTW @jksoegaard – bmike Nov 24 '19 at 23:59
  • Super - Thanks :-) – jksoegaard Nov 25 '19 at 0:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .