1

When I opened Terminal after installing Catalina, this appeared:

The default interactive shell is now zsh.
To update your account to use zsh, please run `chsh -s /bin/zsh`.
For more details, please visit https://support.apple.com/kb/HT208050.

So I copy-pasted the code, it made me enter my password, but nothing happened.

bash-3.2$ chsh -s /bin/zsh
Changing shell for HomoErektus.
Password for HomoErektus: 
chsh: no changes made
bash-3.2$ echo $0
bash

I can't seem to find any answers. Nobody seems to have experienced this same issue. My User Login already has zsh as the default shell.

edit: terminal was fine the next day. Looks like terminal was just acting up. Guess the old "Have you tried turning it off and on again?" does work.

  • 1
    If no changes need to be made your default shell already is zsh. Can you check Terminal preferences (1st tab) to see whether it starts the default shell there or calls bash specifically? – nohillside Nov 23 '19 at 13:44
  • Note that changing your login shell has no effect on existing shells. If you have a Terminal window open running bash, it's going to continue to run bash. Opening a new Terminal window will use the new setting (unless it's overridden in the Terminal preferences). – Gordon Davisson Nov 24 '19 at 22:08
1

Terminal has a setting to use the default shell or run any program.

I would make the election you wish:

enter image description here

If that's not it, you'll have to hunt down each of your initialization files. Before doing that, make a brand new user account to be sure you have a working zsh for that user and terminal overall.

It's probably the obvious item above, though.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .