5

After the Catalina update, the Touch Bar shows a void button on the left of the play button at all times as you can see from this screenshot.

Screenshot with void button

As far as I know, the number of buttons that should appear on the minified control strip is 4... why do I have 5?

If I go into the Settings > Extensions > Touch Bar to customise the control strip, there, while I do the customisation the blank button disappears (see second screenshot).

Screenshot during customisation of control strip

Why does this happen?

[Edit] As I was looking at this post, with a Youtube tab opened along this, the void was replaced by this icon, that is usually what appears when you have media playing.... I don't know if this is correlated or not. (See screenshot below)

Icon changed

  • I put up a triage answer, to fix the bar and software you would boot to recovery and reinstall the OS from Apple to ensure you get EFI/bridgeOS/and macOS all updated directly from Apple. Picking apart the actual prefs isn't something I've seen, but perhaps we can narrow and get someone else to fill in / edit / provide that – bmike Nov 23 '19 at 14:49
2

This is a bug and it's not a new issue. There are several remedies for macOS Catalina:

  • Open Terminal application and run command killall ControlStrip.
  • Open Terminal application and run command sudo pkill TouchBarServer.

Not comfortable running commands in Terminal? Use Activity Monitor to quit TouchBarServer.

Bonus: When you're finished open System Preferences > Extensions > Touch Bar > Customize Control Strip... and use it to replace the right-most button (Siri) with Show Desktop for improved privacy. You'll still be able to access Siri from the expanded strip set but will be less likely to activate Siri on accident while you're trying deleting stuff.

| improve this answer | |
  • Hello @Josh, I have actually tried doing these, but the issue still persist and there are times I get the Mac needs critical update dialog, even when I am connected to a LAN, it still doesn't seem to get updated. I don't know if there is any patch file available, which I can download and install manually for my Touchbar to work again. – Israel Meshileya Jan 6 at 7:50
  • You said you're having issues updating your operating system. If you're under warranty reach out to Apple Support. They may even provide support after the warranty period as they did for me. – Josh Habdas Jan 7 at 8:09
3

Rebooting a few times and killing the TouchBarServer process fixed the problem for me.

I hope this is not a temporary solution and that this condition doesn't happen again.

| improve this answer | |
3

It could be several things.

  • Runtime corruption - one program (or several) gets things off course or the macOS code has bugs that will get fixed in an update
  • Data corruption if this persists across log out / log in and restarts.
  • Good code and faulty hardware - less likely but could be the cause if it’s intermittent and never able to resolve with updates over weeks or months.

I would triage this by setting up a brand new user account on the Mac, logging out from the one where the bar settings are suspect and then into the newly created empty account.

Should the bar be missing the default icons, you can conclude that the operating system and the bar software need to be reloaded / reset.

If the bar behaves, then it's going to be the settings in your user account that need resetting or fixing.

So to answer the main question - it's a corruption in the settings or the controller and the above steps will help you narrow down which path to remediating it you choose.

| improve this answer | |
  • So I rebooted now and it went away... But yesterday I rebooted and nothing happened.... At this point there is not much to debug. I will try what you suggested in the unlucky case that the problem presents again. – Luca Angioloni Nov 23 '19 at 15:05
  • @LucaAngioloni Oh - so it’s run time corruption and doesn’t manifest immediately at log in? I didn’t consider that. I’ll add that as well – bmike Nov 23 '19 at 15:19
  • Yes, you are correct. It happens at run time and it manifests at random times as far as I can tell. – Luca Angioloni Nov 23 '19 at 15:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .