7

I've been having a problem where sometimes I'll forget that my iPhone's volume is set pretty high from a previous use. When I put my AirPods in for a phone call or to listen to music, the volume isn't automatically lowered to a reasonable level. Instead, loud, ear-damaging noise blasts through my AirPods when the call starts or the music plays, and I often have to quickly take them out.

I tried to resolve this by using the new Automation feature in Shortcuts. I created an automation that uses the Bluetooth trigger to run whenever my phone connects to my AirPods. When this happens, it sets the volume to 30%.

So far, so good.

But when I actually use my AirPods, all I get is a notification from Shortcuts giving me the option of running the script (see below).

The little popup is actually kind of irritating - I want Shortcuts to just silently fix the volume without prompting me.

enter image description here

Is it possible to have the Automation feature automatically run the script when the trigger occurs?

0
6

EDIT: This has improved with iOS 14: In iOS 14, Turn off "Ask Before Running" to avoid getting a notification and have automations run automatically in the background. See full list at See https://support.apple.com/guide/shortcuts/enable-or-disable-a-personal-automation-apd602971e63/ios


Not all triggers can make an automation run in the background.

When you Arrive, Leave, connect to CarPlay, or use the Before I Leave or Time of Day triggers, or try to automate connecting to Wi-Fi or Bluetooth, your shortcuts will only show up as notifications and won't run in the background. These are the only triggers where a user may not be in control of their device or it's state, and thus seem to be limited for security reasons – all other triggers can run in the background.

https://imore.com/whats-new-siri-shortcuts-betas. See under "Personal automation". It's a long page, so cmd + F.

https://support.apple.com/guide/shortcuts/enable-or-disable-a-personal-automation-apd602971e63/ios

0
1

When you set up the automation, before you click „Done“, there should be a toggle called „Ask Before Running“. Switch that to off and it should run in the background.

2
  • Hmm I don’t see that setting. I even tried recreating the automation. Could you send a screenshot? – Bill Nov 22 '19 at 17:17
  • 1
    Okay, here's the issue: bluetooth triggers can't be run automatically: support.apple.com/guide/shortcuts/… – Bill Nov 22 '19 at 18:07
0

You can use Autocuts for this

https://adamtow.github.io/autocuts-admin/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .