0

I am trying to create a new "reduced file size" export filter within preview.

Therefore I copied the original file to desktop, made my changes and then I tried to copy back to the folder. This seems not to be permitted. Even with admin account and with sudo on terminal as well.

sudo cp Reduce\ File\ Size.114dpi.qfilter /System/Library/Filters
cp: /System/Library/Filters/Reduce File Size.114dpi.qfilter: Operation not permitted

How can I move this file to the folder?

  • 2
    Make sure you're trying to put them in /Library/Filters, not /System/Library/Filters, or in the Library folder that's inside your home folder. You should put it into /Library/Filters or ~/Library/Filters (just create the folder if it isn't there). – Udhy Nov 21 '19 at 9:27
  • 1
    In Catalina anything in "/" is not writable and in Mojave most things are not without disabling SIP. like @Udhy said put it in your [USERNAME]/library/filters folder – Steve Chambers Nov 21 '19 at 13:49
3

User-created Filters should be saved to /Users/yourUserName/Library/Filters. You may need to create this subfolder if it's not already present in your user Library.

Also, note that the easy way to edit or create a new Filter is to use ColorSync Utility. If you edit the file in a text editor and get invalid XML, it can bring down the whole QuartzFilter system.

ColorSync Utility

CS Utility 2

  • Thank you, never saw this before. The tool itself did not let me create new filters or edit existing ones. I added the file to the user filter settings, then it apeared and I could also change settings on this one. – merlin Nov 25 '19 at 12:08
  • You can't edit existing ones, but you can Duplicate them with the left arrow. You should be able to create new Filters with the + icon bottom left. – benwiggy Nov 25 '19 at 13:39
  • The + icon allows me to create new folders but not filters. – merlin Nov 25 '19 at 14:04
  • If I click on the +, I get an "Untitled" item in the list. That's a Filter! I can then add components to it using the down arrows on the right hand side. See updated image in answer. – benwiggy Nov 25 '19 at 16:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .