1

I have an iMac 4,1 running OS X 10.5.8 that I want to install Lubuntu on. I have a USB drive and a DVD, both with the ISO burned to them, but I can't boot from either. They don't show up in Startup Manager at all. Both show up in the rEFInd menu, but when I try to boot either of them it tells me to make sure I have the latest firmware installed. How can I get one of them to boot? Alternatively, is there a way to burn the ISO directly to a partition on my hard drive and boot that way?

  • Which version of Lubuntu were you trying to install. Was is the name of the ISO file? Are you sure you are using a 32 bit version of Lubuntu? – David Anderson Nov 21 '19 at 1:10
  • @DavidAnderson It's 32 bit. The file name is lubuntu-16.04.5-desktop-i386.iso. – sheratek Nov 21 '19 at 1:35
  • Your idea of not using a flash drive or DVD might work by using VirtualBox to install Lubuntu directly to your hard drive. Usually, the procedure is fairly complicated. So, you really would have to want install Lubuntu. – David Anderson Nov 22 '19 at 7:22
  • Are you still trying to install Lubuntu? – David Anderson Nov 25 '19 at 22:45
  • Apologies for not following up sooner. I believe it may be the DVD drive. I don't have another disc to test it with, but it plays regular DVDs (although it's a little finicky sometimes). When I get a chance I'll clean it out and try again, otherwise I may look into installing it to my hard drive. – sheratek Nov 27 '19 at 13:38
1

I happen to have a 17" iMac 4,1. I burned the lubuntu-16.04.5-desktop-i386.iso image to a RW DVD using a 2011 iMac. I booted from the DVD using the 2011 iMac and ran the software on the DVD to verify the DVD was burned correctly.

To boot from the DVD, you need start the Mac and immediately hold down the option key until the Startup Manager icons appear. Select the DVD icon labelled Windows.

Booting from the DVD using the iMac 4,1 was problematic. Basically, at some point the boot would fail. At least once the boot succeeded. After some research I learned I needed to hit the F6, then include the nomodeset option before selecting Try Lubuntu without installing. Once booted to Lubuntu, I could select the install icon on the desktop to start the installation process.

My iMac 4,1 has the latest firmware updates which are listed below.

Boot ROM Version: IM41.0055.B08
SMC Version (system): 1.1f5

The firmware information can be found under "Hardware Overview" in the System Information application display. Firmware updates for legacy Intel Macs can be downloaded from the Apple website About EFI and SMC firmware updates for Intel-based Mac computers.

Additionally, my iMac 4,1 has 2 GB of RAM installed and has a 1.83 GHz Core Duo (32 bit) processor.

  • Thanks for taking the time to do that! I tested the DVD on a MacBook and it worked, however, it won't even show up as an option on the iMac. I do have the latest firmware. Do you have rEFInd installed, and do you think it could possibly interfere somehow? – sheratek Nov 22 '19 at 4:06
  • I do not have rEFInd installed. I do not think rEFInd would interfere. I would assume the DVD drive does not work. Have you tried testing by booting from a 32 bit Windows (XP SP2, Vista or 7) DVD or a OS X (Leopard or Snow Leopard) DVD? – David Anderson Nov 22 '19 at 6:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .