0

I am having the GPU failure issue and I'm trying to disable some kexts however i'm constantly told operation permitted.

I am following Lizardtrons video on Youtube where it seems atleast 2.2K people have had success however I'm stuck.

https://youtu.be/nFFPk3SeQbQ

I have installed Dosdudes software to automatically delete the kexts for me however it still says SIP is enabled.

I am running MacOS Sierra 10.12.6. I can add more info if needed.

I cannot for the life of me disable csrutil in terminal, safe mode or recovery mode. It says the command is not found. It is as if computer does not know the command.

However when I type in 'csrutil status' in terminal on the desktop it actually says SIP enabled.

So its recognising it on the desktop terminal but not on safe mode(cmd S) and Recovery mode (cmd R).

I have also tried internet recovery to newest install newest OS however it only promts me to install OX Lion.

I installed El Capitan onto an external HD to see if I could boot a new OS from that but when holding option key prior to boot, the only HD that comes up is the internal drive and not the external boot drive.

I am running MacOS Sierra 10.12.6

All i need to do is 'csrutil disable' so operations can be permitted.

I've been at it for 3 days now and I really don't want to give up as I've got a week off work and decided to dig this out of its death!

Any help is greatly appricieated. I am not 100% tech savy however I can adapt fast with instructions etc👍🏻

Also sorry if the question is all over the place.

13
  • csrutil should exist in all modes (as long as you're running 10.11 or later), but should only be able to enable/disable SIP in Recovery mode. Try starting in Recovery mode, and run sw_vers to make sure your Recovery environment is up to date. Nov 20, 2019 at 18:53
  • Thanks for your reply, after typing in sw_vers it comes back with product name: mac os x. Productversion: 10.7.5. Build version 11G63. Nov 20, 2019 at 19:05
  • That's too old a version to have csrutil. It sounds like either it's running Internet Recovery, or the Recovery partition on your computer never got properly updated. Try restarting with Command-Option-R; that should start in the latest Recovery version your Mac can run; see what sw_vers shows then, and if it's 10.11 or later (it should be) see if csrutil is available. Nov 20, 2019 at 19:27
  • Ah right ok, i'll start up with that command and get back to you in 5 minutes. Thanks for your help by the way Nov 20, 2019 at 19:32
  • Just checked in terminal via cmd-option-R and its still the same. Product version 10.7 5. Build version 11G63 Nov 20, 2019 at 19:37

1 Answer 1

1

Just incase anyone had this same issue.

I had to use a new external HD (backed up everything onto it) and booted with that using option button.

Then erased the internal disk using disk utility and it then allowed me to do a fresh MacOS which then updated the recover software to 10.12.6 Sierra.

Which then therefore allowed me to disable csrutil in Recovery mode.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .