0

After having installed macOS Catalina, I cannot launch Parallels Desktop anymore.

Launching Parallels Desktop from the dock results in the message in the image below. It says that I should "Allow" Parallels Desktop in "Security and Privacy" settings, but it's not showing up there.

How can I manually "Allow" Parallels Desktop in "Security and Privacy" settings, when it's not showing up there?

enter image description here

1

Your screen capture shows the Security and Privacy > :General" tab. Did you look under the "Privacy" tab?

There will be a list of categories on the left and then the permissions of each app on the right. You will need to select the categories on the left one at a time (I'd start with "Accessibility") and authorize any instance of Parallels that requests permissions for that app..

To do this you will first have to click the padlock icon and authenticate with an admin password.

| improve this answer | |
  • Yes, I’ve looked in Privacy too, but nothing shows up. – Shuzheng Nov 20 '19 at 15:32
0

Here is the solution you can try, might be helpful for you

  1. Quit out of System Preferences

  2. Open the Terminal app from the /Applications/Utilities/ folder and then enter the following command syntax:

    sudo spctl --master-disable
    
  3. Hit return and authenticate with an admin password
  4. Relaunch System Preferences and go to “Security & Privacy” and the “General” tab
  5. You will now see the “Anywhere” option under ‘Allow apps downloaded from:’
  6. Try to open Parallel Desktop.

Nearly every Mac user should leave this feature enabled in the default state. If you do not have the ability to easily discern which apps are legitimate or not, you should absolutely not change this option.

You can enable it back again

    sudo spctl --master-enable
| improve this answer | |
  • What’s the effect of spctl --master-disable? – Shuzheng Nov 21 '19 at 5:31
  • Sorry, the solution doesn't work. I'm still stuck at the "Launch Parallels Desktop" screen, where no requests show up in "Security and Privacy" settings. – Shuzheng Nov 21 '19 at 7:52
  • Did you try to open the General tab first and re-open the Parallel Desktop screen, so it might popup back again? Else, try to boot it on SafeMode, restart after it and test back again. It should work in that way too. – Udhy Nov 21 '19 at 9:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .