1

I have a brand new MacBook Pro.

I have Xcode 11.x installed.

I have react-native-cli installed.

why doesn't it want to obey me with react-native run-ios?

--verbose is not giving me anything helpful.

node is installed, npm is installed

I have even tried, npx react-native run-ios.

The error I am getting in the terminal is as follows:

info Found Xcode workspace "NFIBEngage.xcworkspace"
error Could not find "iPhone X" simulator. Run CLI with --verbose flag for more details.

I am on Mojave OS

I thought the issue might be that I need to install Cocoapods, but after installing it, I am still getting the same error message.

I thought it was CocoaPods because I was able to create a brand new react-native application and it asked me for CocoaPods and I was able to boot that one up successfully.

I removed Xcode and reinstalled to a lower version of 11.1 from the original 11.2 that I had, but still had the same issue.

You must log in to answer this question.

Browse other questions tagged .