15

On my mid 2012 MBP running macOS 10.15.1 (Catalina) I had an application create a sound output device. I deleted the application in finder by moving it to the trash. I know this method doesn't uninstall any dependencies or extra things the application might have installed which is why I'm having this issue. I went into the Audio MIDI Setup, but the (-) symbol is greyed out for the output, which is named AudioJingle. How would I go about uninstalling this output device?

2 Answers 2

26

Posting here for reference if you still have the problem and for other searching the answer was found at the Apple Community Site

Remove the following files:

  1. /Library/Audio/Plug-Ins/HAL/Audiojingle.driver
  2. /Library/LaunchDaemons/com.audiojinglex.soundtree.agent.plist
  3. /Library/LaunchAgents/com.audiojinglex.soundtree.agent.plist

Then restart coreaudiod using terminal sudo /bin/launchctl kill SIGTERM system/com.apple.audio.coreaudiod || /usr/bin/killall coreaudiod

or use the following script it does the same thing (I personally did it manually)

#!/bin/bash

# remove driver
DRIVER_NAME="Audiojingle.driver"
DRIVER_INSTALL_PATH="/Library/Audio/Plug-Ins/HAL/${DRIVER_NAME}"
if [  -d "${DRIVER_INSTALL_PATH}" ]; then
    /bin/rm -rf "${DRIVER_INSTALL_PATH}" || exit 1
fi

# remove helper plist

LAUNCHD_PLIST_INSTALL_PATH="/Library/LaunchDaemons"
LAUNCHD_PLIST_INSTALL_PATH_BACKUP="/Library/LaunchAgents"
LAUNCHD_PLIST_FILENAME="com.audiojinglex.soundtree.agent.plist"
LAUNCHD_PLIST="${LAUNCHD_PLIST_INSTALL_PATH}/${LAUNCHD_PLIST_FILENAME}"
LAUNCHD_PLIST_BACKUP="${LAUNCHD_PLIST_INSTALL_PATH_BACKUP}/${LAUNCHD_PLIST_FILENAME}"

# romove the plist.
if [ -e "${LAUNCHD_PLIST}" ]; then
    /bin/rm -f "${LAUNCHD_PLIST}"
fi

if [ -e "${LAUNCHD_PLIST_BACKUP}" ]; then
    /bin/rm -f "${LAUNCHD_PLIST_BACKUP}"
fi

#/usr/bin/killall -u "_coreaudiod" "coreaudiod"
/bin/launchctl kill SIGTERM system/com.apple.audio.coreaudiod || /usr/bin/killall coreaudiod

echo "restart coreaudio"

sleep 2
1

This is a simple approach, but it's amazing just how often the simple approach does the trick.

In both ~/Library & /Library enter the name of the thing you want rid of in the Finder window search box, & select "Name Matches" when it appears.

Name Matches

The user Library, ~/Library, is hidden in recent versions of mac OS, so use Command-Shift-g (or using menus, Go > Go to Folder...) to get there. I added it to the Favourites sextion of my Finder sidebar so I don't have to continue doing this.

Finder sidebar

While you're in those Library folders, a scan of the folder names within might reveal likely locations for what you're looking for. In my ~/Library there's a folder /Audio for example.

Also look in /Application Support & /Preferences within both Library folders, & looking by reverse domain sytle identifiers as well as direct names, for anything left behind by your deeted app.

Hope this helps.

1
  • Unfortunately I tried this and deleted all the instances of AudioJingle and the software it came from but the problem is still persisting. Nov 20, 2019 at 14:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .