1

I have the Sony MX1000 Bluetooth headphones, that can only connect to 1 Bluetooth source. So after work I put my MacBook to sleep, and would like to connect my headphones to my phone. This is not possible though, because my MacBook is still holding on to it, draining it's battery in the process.

To stop my mac from keeping its connections open, I tried this solution where I set stand-by mode as the default with sudo pmset -a hibernatemode 25 and then invoke it with Command+Option+Eject (Computer sleep), but it didn't work. The bluetooth stays on.

Does anyone have any other ideas?

  • Kind of a low tech answer, but how about turning your headphones off, then closing your macbook. Turn them back on and they should be able to connect to your phone? Bluetooth is often not a well implemented technology and seems to go wrong a decent percentage of the time. – FiddleDeDee Nov 21 '19 at 10:15
  • @FiddleDeDee, no my MacBook immediately grabs the connection again. Your trick sometimes worked with my 2015 MacBook if I timed it right (making my phone search before turning the headphones on), but with the 2017 version my phone doesn't stand a chance. – Herman Nov 21 '19 at 12:43
1

You could install blueutil and SleepWatcher via homebrew and set a .sleep code to do "/usr/local/bin/blueutil -p 0" in order to disable bluetooth when going to sleep mode. I had the same issue and this did the trick !

To use SleepWatcher: make a shell script in your home directory named .sleep and give it permission with the command chmod +x ~/.sleep.

You also can do a .wake code to turn bluetooth back on with blueutil -p 1 when waking up. You can find out how to use SleepWatcher here

You can do all of this with Keyboard Maestro too, if you prefer a GUI tool. You can have Keyboard Maestro call blueutil to control your Bluetooth. However, the first thing to do is make sure that “Enable Power Nap” is OFF in System Preferences under Energy Saver.

  • I wonder if this might be simpler (guessing here as I don't have any Bluetooth headphones). In system Preferences > Energy Saver turn off "Power Nap" and Bluetooth > Advanced uncheck the bottom check mark that allows Bluetooth devices to wake the Mac. I'm thinking that might do the trick. – Steve Chambers Nov 18 '19 at 13:34
  • Well, I had to make a .sleep shell even with this feature disable.. the issue is that the macbook turn on Bluetooth otherwise, and then the sony headphone connect to it by himself and you can’t connect to your phone afterward – Edd Growl Nov 18 '19 at 13:54
  • I've tried your solution Steve Chambers, alas it didn't work. – Herman Nov 18 '19 at 13:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .