2

I think I have a failed installation issue from trying to install Catalina. Apparently there wasn’t enough space, and when it restarted I wasn’t able to log into my MacBook. Every time I do, the progress bar goes halfway, and then the MacBook shuts down.

I’ve tried to use command + S boot up, but it just shows the login screen as usual. It doesn’t show the terminal, except when I shut it back down or restart (for a brief second).

This means I have to use recovery mode’s terminal. I need to use the terminal in recovery mode to delete my Adobe apps so I can free up space to reinstall Catalina from recovery mode. The problem is, when I navigate to cd /Applications, there’s nothing but Safari.app and Utilities. How do I find my Adobe apps?!

enter image description here

I ran ls in cd /Volumes, and it says:

Macintosh HD
Macintosh HD - Data
macOS Base System
  • 1
    best guess… from Recovery /Applications is looking at the wrong drive. Try /Volumes/[Macintosh HD - Data]/Applications/ Double-check the drive name, Catalina renames them - support.apple.com/en-us/HT210650 – Tetsujin Nov 17 '19 at 15:53
  • The df command needs to be run to show the mounted volumes. / is the installer that’s running and not your actual internal drive with your apps and your data. – bmike Nov 17 '19 at 15:57
  • I tried the first suggestion, and it told me it wasn’t a location. – Eds94 Nov 17 '19 at 16:15
  • What is the df command exactly? I used it to show what was taking the most space, but it still wouldn’t let me navigate to Macintosh HD - Data. – Eds94 Nov 17 '19 at 16:16
1

Using the Terminal app. Look in /Volumes to see if the name of your normal desktop hard drive is there.

If so cd to /Volumes/< Insert your home volume name >/Applications

That will take you to the applications folder of your desktop. Where you can remove unneeded items.

If not present, you will need to mount it. If using a standard disk with a recovery volume you can issue the following command (with root permission)

mkdir /Volumes/mydrive
mount /dev/disk1s5 /Volumes/mydrive
cd /Volumes/mydrive

an "ls" should show you the Applications directory where you can remove the needed items.

  • Recovery has already mounted the volume in most cases. – bmike Nov 17 '19 at 16:48
  • @SamuraiJack42 Ok I was able to get to /Volumes, but if I cd /Volumes/Macintosh HD - Data/Applications, it tell me no such file or directory. I imagine I haven’t typed the Macintosh HD - Data correctly? – Eds94 Nov 17 '19 at 16:53
  • @Eds94 Try cd "/Volumes/Macintosh HD - Data/Applications" (with the quotes). – nohillside Nov 17 '19 at 17:57
  • @nohillside Thank you. I still got the no such file directory message though. – Eds94 Nov 17 '19 at 20:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .