1

I have a late 2011 MacBook Pro and the disk doesn't isn't being recognised.

So far I’ve tried:

  • using disk utility, but obviously I can’t repair a disk that doesn’t appear in the left column
  • running fsck - but it says that everything seems okay even though I still get the folder with the “?” whenever I try booting
  • holding down option on boot up, but only the internet recovery appears
  • running the hardware test which results in it coming back clean, so it doesn’t appear to be damaged.

How else might I troubleshoot this?

  • Have you recently replaced your drive? Please update your question with output of sudo diskutil list – TimD Nov 16 '19 at 6:16
1

The folder icon with question mark that you're seeing appears when no bootable media is found, and in your case seems indicative of SATA cable failure or hard drive failure. Your local Apple Store can help diagnose this (they have a more thorough in-house hardware test OS that isn't publicly available), but I'd place my bets on cable failure, given your symptoms and how failure-prone they are known to be.

If it's just the cable, they can replace it for you (typically £100 for parts and labour), or you can get the part and tools for around £15 and replace it yourself if you have the time and patience. If it's the hard drive itself, you'll obviously need to replace it, and your data is likely lost — in this situation, don't attempt to recover the data yourself; you'll do more harm than good. Instead, consult a data recovery specialist if you desperately need the data and don't have a backup.

To attempt some better diagnostics at home, make a bootable Ubuntu USB and see if that detects your drive. I've had some luck in the past with that, in situations where a SATA cable has failed sufficiently that the Mac EFI and macOS (including Recovery) refuse to show it, but Linux will do its best to provide info. When in Ubuntu, open the Disks app to see if your drive is detected. If it is, check the SMART report (select the disk in the left sidebar, click the three-line icon in the upper-right, click "SMART Data & Self-Tests...") If all is reported good, the cable is almost certainly the issue.

P.S. "obviously I can’t repair a disk that doesn’t appear in [Disk Utility]" — Likewise, you cannot use fsck to check a filesystem that the OS cannot see, hence why it says everything is fine.

|improve this answer|||||
  • 1
    This. I've had similar problems - a quick way to check is to crack the case open and try and mount the disk externally via a caddy and USB. If it reads ok, likely to be the cable. I'm on my third. Replacing them yourself is not to fiddly if you're vaguely comfortable with opening electronics. Just be careful with the replacement cable, as they are quite delicate! – FiddleDeDee Nov 16 '19 at 11:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .