2

Hi before updating my macOS to 10.13.6 I was able to use the next command:

defaults write com.apple.dashboard devmode YES

to drag my safari web clip widgets from Dashboard to my desktop, but after I updated the OS version to High Sierra I face the error after a widget is placed on the desktop doesn't appear and I see the error right in the center of the empty widget which had been placed on the desktop:

Missing Plug-in

despite the dashboard widgets such as Clock and Calendar display on the desktop perfectly.

I googled about it but found nothing and can't guess what's wrong. But I found that this feature of placing widgets from Dashboard to desktop works well with the same OS version which I use (High Sierra, 10.13.6.). I guess something wrong with my OS / Safari. I can't update my OS right now so I would be appreciated for advice about how to fix this without updating my OS to the latest. Safari version: 13.0.3 (no updates available in AppStore for my OS version.

What I tried which did not help:

write com.apple.dashboard devmode NO
write com.apple.dashboard devmode YES
killall Dock
reboot

One of the web clips in the Dashboard is very important for me so I'd like to see it on my desktop again.

Thanks for your help!

3
  • May OS reinstalling with the same version help? Thanks.
    – Dmitry
    Commented Nov 13, 2019 at 14:55
  • I found the same problem here: discussions.apple.com/thread/250676276 and suddenly after killing the Dashboard process I found the web clip on the desktop has worked! I added killing command of both Dashboard and Dock in my cron jobs in order to renew the info in the webclip as well as to fix Missing Plug-in error. Now my question is if there's a way to go without this crutch? Thanks.
    – Dmitry
    Commented Nov 13, 2019 at 19:03
  • Unite app for macOS did what I wanted!
    – Dmitry
    Commented Dec 22, 2022 at 9:32

1 Answer 1

0

Here's a technique I've found that fixes this issue, at least on a couple of my macOS 10.14 systems:

  1. Open System Preferences and pick Mission Control
  2. Change the Dashboard setting to "Off"
  3. Open a terminal window and execute the following to restart the Dock:
    launchctl stop com.apple.Dock.agent
    ...if the Dock doesn't relaunch, also execute:
    launchctl start com.apple.Dock.agent
  4. Change the Dashboard setting back to "As Overlay" or "As Space"

Hopefully your web clips are working again! No need to blow away preferences and set everything up again.

edit: While this did work for me a few times, it has now failed to work today. So your mileage may vary.

1
  • Thanks, but I updated to Monterey and found Unite app that made all (!) that I needed!
    – Dmitry
    Commented Dec 22, 2022 at 9:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .