1

"user" can't do it either. Permission of Desktop/ is set to 700 and owned by "user". Here's the sderr output for ls -R command in the home directory:

ls: Desktop: Operation not permitted ls: AddressBook: Operation not permitted ls: CallHistoryDB: Operation not permitted ls: CallHistoryTransactions: Operation not permitted ls: com.apple.TCC: Operation not permitted ls: com.apple.sharedfilelist: Operation not permitted ls: CloudKit: Operation not permitted ls: com.apple.ap.adprivacyd: Operation not permitted ls: Calendars: Operation not permitted ls: com.apple.CloudDocs.MobileDocumentsFileProvider: Operation not permitted ls: com.apple.Home: Operation not permitted ls: com.apple.Safari: Operation not permitted ls: com.apple.news: Operation not permitted ls: Cookies: Operation not permitted ls: HomeKit: Operation not permitted ls: IdentityServices: Operation not permitted ls: Mail: Operation not permitted ls: Messages: Operation not permitted ls: CoreSpotlight: Operation not permitted ls: PersonalizationPortrait: Operation not permitted ls: Safari: Operation not permitted ls: Sharing: Operation not permitted ls: Suggestions: Operation not permitted

  • 1
    Transparency Consent and Control (TCC) is blocking it. This is based on the app (Terminal), not the user (/root) account. You need to grant Terminal full disk access in System Preferences -> Security & Privacy pane -> Privacy tab. – Gordon Davisson Nov 13 at 6:21
1

You need to add Terminal to the list of apps that have Full Disk Access in the Privacy pane of System Preferences > Security & Privacy.

Unlock the padlock in the bottom left, and drag the Terminal app icon onto the window.

Privacy pane

  • Actually, all I had to was go to Privacy > Files and Folders, and authorize Terminal to access the Desktop – Case39 Nov 13 at 8:08
  • If you're on Catalina, you'll need both. – benwiggy Nov 13 at 10:04
  • For what? All I wanted to do was to access a file in Destop and it worked. – Case39 Nov 13 at 13:49
  • For all the things listed in stderr. – benwiggy Nov 13 at 14:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .