2

Custom icons for any kind of item (e.g., folder, file, app) are displayed in lower quality in the Finder when choosing smaller sizes (i.e., below 32px). I usually set the Finder to display my files in the list view option, which allows us to set the icon size to either small or large (which I assume corresponds to 16px and 32px, respectively). But regardless of choosing the list view or any other option in the Finder, any item that uses a custom icon that is set to 32px or below is displayed in a lower quality. By “lower quality” I’m referring to the icon’s definition in the sense that it is displayed blurrier and less crisp, with white pixels around the edges. The edges seem less crisp and in a few icons there is an overall drop in definition. When inspecting the icons in Preview.app, icon sizes below 32px are indeed of worse quality in the custom icon folder.

This issue occurs regardless of using the “copy-paste” or the “drag .icns” methods through “get info” to assign custom icons (see https://www.lifewire.com/personalize-mac-by-changing-desktop-icons-2260911). This issue occurs regardless of using “macOS’ default system icons” (see http://osxdaily.com/2014/07/27/mac-os-x-system-icons-location/) or any other icons to assign custom icons. This issue appears to occur regardless of using a retina display or not. This issue occurs in macOS Catalina and has been on macOS at least since the previous iteration (macOS Mojave).

The example in this screenshot (https://www.dropbox.com/s/wmsvz9e4xgu5uya/custom_icon_quality.png?dl=1) shows a comparison between the original “Downloads” folder (“Descargas” in Portuguese) and a folder (named “Descargas custom icon) assigned with the “DownloadsFolder.icns” located in the previously mentioned “macOS’ default system icons” folder. The lower part of the image is magnified in order to better see the issue.

enter image description here

I’m assuming this is a macOS bug and not simply something there might be a workaround. I have already submitted a feedback entry to Apple in the hope this issue is addressed.

I presume everyone is getting this issue, right? Does anyone get different results? Has anyone go any answer from Apple?

Thanks for listening!!

0

The solution for this is to not add @2x icon resources if you just want to use these custom system icons on a @1x screen via LiteIcon on 10.9 - 10.15. Additionally if you want to just copy and paste from one icon to another, unfortunately this has been broken, but you can use an app to do this. For example I tried to set custom icons via an old an unsupported app CandyBar and it worked well and did not present these pixel errors at the size of 32×32 px.

3
  • Thank you for taking the time to help, @maxim-minim-kopeikin! From what I remember, LiteIcon and CandyBar are only for changing volume/system/app icons, aren't they? I'm going to try to identify and remove the @2x icon resource from the intended .icns file. Though, you've mentioned that the copy-paste method for changing icons was broken; in which way did you mean this?
    – pedrobL
    Jun 29 at 18:25
  • CandyBar is primarily for changing system icons indeed, but it also has a "Quick Drop" feature, where you can select an icon from a collection and drop any directory or app onto that zone, which will apply that custom icon. It might even be that adding icons from here also creates retina assets, but does not bodge the @1x size masks. If you succeed let me know. Jul 4 at 7:14
  • 1
    The "Quick Drop" feature in CandyBar worked flawlessly and the issue no longer occurs through this method. In fact, as an added bonus, using this method even applies the dark mode correctly to the icon, which is something I did not expect. Again, thank you @maxim-minim-kopeikin!
    – pedrobL
    Jul 5 at 11:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .