1

It just keeps giving the Update option, even after "updating" the app. Take a look at this video. Clicking the update button starts the process, but in the end, it reverts back to "update" instead of completing the process and becoming "open"

How do I update the app ?

2
  • Have you tried restarting your Mac? If that doesn't do any difference, could you keep the Console application open and see if you get any error messages while performing the operation? – molle Nov 11 '19 at 14:27
  • @molle the console is a mess, but here are the errors that App Store sptis out. – Birowsky Nov 12 '19 at 8:54
2

Delete and re-install the app. Unless the app in question is Xcode, I'd be doing the same for all apps, if update fails.

4
  • 1
    This is what I have been doing lately when I run into this situation. The Mac App Store seems to do a much better job installing than updating so I let it do what it prefers. – TJ Luoma Nov 11 '19 at 16:47
  • Are you and fsb on Catalina ? I just updated an app on Mojave smoothly. – anki Nov 11 '19 at 16:55
  • I'm on Catalina but I've had this problem intermittently on Mac for years. – fsb Nov 11 '19 at 17:15
  • 1
    I'm on Mojave but this probably has existed back to High Sierra at least. I'm running Macs that still have it in 10.13. And I skipped 10.12 so it might go back even further than that. – TJ Luoma Nov 11 '19 at 23:44
0

This is a bug in the Mac App Store. It's happened to me several times with different apps.

I've contacted developers about it and they told me the only resolution is to quit all apps and do a hard restart of the Mac (shut down then restart, don't just do a restart).

Doing that worked for me, although sometimes I have to do it twice to get it to work. I don't know the root cause, I only know that this workaround seems to do the trick.

If you search this site you'll find many similar issues. You can also try the answers already provided. I didn't mark your question as a duplicate because I'm not sure if the cause is the same as those.

2
  • Tried twice. No luck. Thanx. – Birowsky Nov 12 '19 at 8:49
  • Doesn't surprise me, that's happened to me a few times. I've had to do it a few times to get some apps to uninstall. – fsb Nov 12 '19 at 13:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .