1

It often happens to me that I open my MacBook Pro to use it while traveling, only to find out that I can't use it because the effin' Magic is locked away in some luggage, and the trackpad is not clicking. Of course I cannot turn the Bluetooth off, since the trackpad doesn't click. But the weirdest thing is that I always turn the Magic Mouse off before putting it away (I move the slide on the bottom so that the green color is not showing), yet it still prevents me from using the trackpad!

Why does that happen? What's with this brilliant design choice that one couldn't use the trackpad if one also has a Magic Mouse?

1

This is a feature, not a bug. The idea is that you might want to disable the trackpad if you are using a mouse because, for example, you accidentally hit the trackpad with the palm of your hand.

I thought it was turned off by default, but in any case, here’s how to turn it on or off:

System Preferences » Accessibility

System Preferences » Accessibility » Mouse & Trackpad

[ ] Ignore built-in trackpad when mouse or wireless trackpad is present

For more details: OSX Daily: Ignoring Built-in Trackpad Input When Using External Mouse with MacBook

Turning Bluetooth On / Off Without the Mouse

1) If you have brew installed, you can easily install blueutil via brew install blueutil. Then you can disable Bluetooth by going to Terminal and typing:

blueutil --power 0

2) “Full Keyboard Access” can also help:

System Preferences » Keyboard Shortcuts

Once that is enabled, open Bluetooth preferences in System Preferences and press Tab to highlight the “Turn Bluetooth Off” button, as shown here:

System Preferences » Bluetooth

Then press the Spacebar to turn Bluetooth Off.

3) If you use Alfred or LaunchBar, I suspect they probably have tools to allow you to toggle bluetooth as well.

3
  • Wow thanks! That's great. Just one question; is it safe to install brew? I seem to remember that it was discouraged. I can also ask that as a separate question if you prefer. – DeltaIV Nov 12 '19 at 7:00
  • Incredibly enough, [ ] Ignore built-in trackpad when mouse or wireless trackpad is present is indeed turned off in my laptop, but I still get the no-click issue every now & then! However, this Alfred workflow fixed everything for me: alfredforum.com/topic/5122-bluetooth-toggle note that to make it work on Mojave+, you need to modify the Applescript as described in the thread. – DeltaIV Nov 12 '19 at 9:35
  • 1
    I think brew is as safe as most anything else you might do online. – TJ Luoma Nov 13 '19 at 1:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .