5

I'm trying to install the torrent downloader Vuze and every time I try to open the Vuze Installer via the terminal, in my case,

sudo /Users/naza/Downloads/VuzeInstaller.app

after put the password the therminal says

sudo: /Users/naza/Downloads/VuzeInstaller.app: command not found

I'm a new MacOS user but I know I can install the app by just going root and log in as root user in another session but I read that is recommended to do it with sudo via the terminal.

I just installed MacOS Catalina, it would be weird if something, as the sudo command, is missing.

I also tried to use the SU command

su /Users/naza/Downloads/VuzeInstaller.app

but it doesn't seem to work. The terminal answers su: Sorry. I read that's because the command isn't on for non-root users, same if I try sudo su /Users/naza/Downloads/VuzeInstaller.app, the terminal respond su: unknown login: su.

7
  • You shouldn't need to run the installer as root. I took a quick look at the instructions on the Vuze website's download page, and it just says to double-click the installer normally. root is normally disabled for login on macOS, and it's really rare to see a graphical app (which a .app is) that's supposed to run as root. – Gordon Davisson Nov 10 '19 at 9:19
  • The installer, once open, says "you must be logged in as root when installing this program" – user10926715 Nov 10 '19 at 14:21
  • I just tried installing VuzeInstaller (it is a java program I think not a normal app) and it only gave the "You must be logged in as root" message after I cancel the request to enter administrator name/password from install4j program. Did you see this prompt? – lx07 Nov 10 '19 at 19:01
  • It just gives me the you must be logged in as root message, it's weird. So, there's no way to open an executable as root via the terminal? – user10926715 Nov 12 '19 at 18:25
  • Same problem here: "you must be logged in as root when installing this program", and using sudo with the terminal. – Hikarus Jan 19 '20 at 15:55
7

You need to execute the unix executable, normally found in some.app/Contents/MacOS. To browse the app contents, right click on the app, and choose "Show package Contents".

You can simply drag and drop the executable in a Terminal window to get its path. Or you can right click, hold alt and choose "Copy as pathname".

Run the command below first, using sudo on any executable is not recommended.

/Volumes/Vuze\ Installer/Vuze\ Installer.app/Contents/MacOS/JavaApplicationStub

This of course assumes that you have already mounted the .dmg file downloaded from Vuze website.

1
  • Why not copy the installer app from DMG to ~/Downloads or /Applications ? – anki Jan 21 '20 at 16:59
1

I could only solve this by enabling the root user via MacOS' DIRECTORY UTILITY (which you can find via spotlight or /System/Library/CoreServices/Applications/Directory Utility.app). Within the app, click on the usual lock to make changes, then go to the Edit Menu ⟶ Enable Root User. You will be prompted to create a password for the root user, which can be the same from your admin user. You can then log out your user, log in with root, install vuze, log in again with your usual user, and Vuze is ready to run. Ta-da! :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .