2

I have three email accounts that I use two different Mail apps to manage on my iPhone 5 (iOS 10.3.4). I read two accounts with Apple Mail, and one with myMail. This allows me to keep work and personal accounts separate. Unfortunately all three accounts are always available as the sender in Mail even though myMail only sends from the accounts it manages. This means that I sometimes accidentally send mail from the wrong account when using Mail. Is there any way to restrict the accounts that Apple Mail can use, so that Mail can only use the accounts it manages like myMail only uses the account it manages?

  • Good question! I DO know that MS Outlook is free and uses their own settings, not the system wide one. – Steve Chambers Nov 9 '19 at 23:59
  • @SteveChambers Thanks for your comment, as it has made me clarify the problem. myMail can send only from the account it manages. It's Apple Mail that seems to have all three accounts available. I'd prefer not to use Outlook. But it might be worth hunting for a different mail client indeed. – Alan Munn Nov 10 '19 at 0:24
  • What are the accounts under Settings -> Passwords and accounts ? Temporarily, you can set a default account under Settings → Mail, in the end. – anki Nov 10 '19 at 17:25
  • @ankii The other account did show up in the accounts part of the Mail preferences, which I had never noticed. Deleting it, solves the problem. If you want to post that as an answer I'll accept it. – Alan Munn Nov 10 '19 at 19:52
  • But is mymail working now ? – anki Nov 10 '19 at 19:57
2

As resolved in comments, the account got added in mail app too. It can be removed from Settings → Passwords and Accounts.

For temporary fix, setting a default account under Mail Preferences can help.

Outgoing server's settings can be also disoriented under the Account's Server settings IF it is a work account and allows interface like:

enter image description here

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .