3

I have Logic Pro X 10.2.4.

I never noticed this problem before today:

I started having the same problem as shown in this reddit post:

everytime I try to upload an mp3 file into logic, it speeds up the audio by a whole lot. I've made sure that the sample rate of the audio file and the project is the same but it still doesn't make a difference. All the previously saved projects that had audio imported into them don't have a problem but if I try to upload a new audio file into those projects, I am encountering the same problem

I have noticed that this doesn't affect only mp3 files (downloaded from the internet), but also m4a files recorded in my iPhone (with the factory voice recorder app) and sent to my MacBook.

The sample rate of Logic (in Project Settings > Audio) is 44.1kHz, as is the sample rate of all the files I try to import (except potentially the m4a files, soxi doesn't work on m4a though so I don't know their sample rates).

Here is an example of an audio file which I may attempt to import:

https://soundcloud.com/george-bakewell/originalrecording

here it is after dragging and dropping from Finder into Logic:

https://soundcloud.com/george-bakewell/logicmangling

It sounds like some parts are just ... skipped. It sounds the same in Logic playback and after exporting (bouncing).


I'm temporarily using the 'fix' that the reddit OP noted:

I managed to bypass the issue by just converting all of my mp3 files to wav files.

I just ran a few quick

ffmpeg -i originalrecording.m4a originalrecording.wav
ffmpeg -i originalrecording2.mp3 originalrecording2.wav

etc.

Drag and drop the WAV files instead of the original files, and logic no longer chops them up weirdly.


How come this happens though?

What's the root of this problem, and how can it be resolved?

1

Ok so this is a known issue when upgrading to Catalina. I found a solution and I can't explain how/why it works, but it did work.

I put the mp3 I was trying to use into Garageband, then selected Share>Export Song To Disk & saved the file as an mp3. I then went into Logic, File>Import>Audio File, selected the saved file from GarageBand and it somehow imported without issue! Can't explain why it worked but it did.

0

You don't have to go thru all of that. Just do the file>import>audiofile and you should be good. For some reason the glitch occurs when you drag and drop when having the newest mac OS. Cheers!

0

I HAVE FOUND A WORKAROUND! After incredible frustration with issue I have discovered a temporary but effective way around this problem.

  1. Simply convert your audio files to MP4 format using an online converter (I use Zamzar)
  2. Drop the MP4 file into your project and select 'Extract Audio'

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .