0

I have r/w permissions on my NTFS drive from Terminal by editing the fstab file with:

sudo nano /etc/fstab

adding

LABEL=drivename none ntfs rw,auto,nobrowse

However, due to the nobrowse option, the drive doesn't appear on the Desktop when I connect it, and it's annoying to open always Utility Disk.

I don't want to create an alias with: sudo ln -s /Volumes ~/Desktop/Volumes

Is there a command to show my NTFS drive automatically on the Desktop?

  • From the mount manual page, for the nobrowse option, it states, "This option indicates that the mount point should not be visible via the GUI (i.e., appear on the Desktop as a separate volume).". So why not remove the nobrowse option, so it will appear on the Desktop? (This assumes that the [√] External disks checkbox is checked in: Finder > Preferences… > General) That said, macOS is good at corrupting an NTFS volume when mounted as writable and it has no built-in capability to repair a corrupted NTFS volume! – user3439894 Nov 8 at 15:00
  • @user3439894 So there's not solution? I've to use the open /Volumes command from Terminal to transfer files? – Bug-Gy Nov 8 at 15:21
  • So why not remove the nobrowse option, so it will appear on the Desktop? – user3439894 Nov 8 at 16:17
  • Because without this option the drive is only read mode, at least for me. – Bug-Gy Nov 8 at 16:35
  • Another option would be to use a Folder Action, attached to /Volumes, to automatically open the new mount point. My answer here could be used and customized to only act when a given disk is mounted. – user3439894 Nov 8 at 16:45

You must log in to answer this question.

Browse other questions tagged .