3

My default search engine in Safari is Bing (Amazon Gift cards FTW!).

I usually search Google by starting to type "goo" and hitting tab to to autocomplete, which enters search engine mode.

However, Google searches always come here. I removed apple.stackexchange.com from Manage Websites in Safari Search preferences: Safari > Preferences > Search But every time I visit the site it is automatically readded.

I don't mind it being there, but why are Google searches directing here?

safari quick search selects ask different instead of google

4
  • Could you turn off Pre-load top hit, disable all extensions. restart Safari and then try it ?
    – anki
    Nov 8, 2019 at 9:26
  • Yes, and strangely, even when apple.stackechange.com is not in the list it still comes here. Nov 8, 2019 at 9:30
  • I won't recommend removing the site from history, however, you can try removing it from "Manage Website data" under privacy and then use cmd + Shift + E or empty cache under Develop menu
    – anki
    Nov 8, 2019 at 9:32
  • @ankii Empty Cache doesn't give any sort of feedback. But I tried your suggestions. EditL: And they worked! Nov 8, 2019 at 10:58

1 Answer 1

1

https://shouldiblamecaching.com

I won't recommend removing the site from history, however, you can try removing it from "Manage Website data" under Safari privacy preferences and then use command + option +E or Empty Cache under Develop menu.

3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .