0

Sometimes when I opened up the AirPods case near the bottom of the iPhone 7 Plus or iPhone X, the info of the AirPods will be shown (percent of battery left for case and AirPods).

But other times no matter how many times I tried, it won't show but the AirPods can still play music through that iPhone. The only way I can get it to display again is to press that reset button on the AirPods case for 5 seconds or so and place it near the bottom of the iPhone again and press "Connect". Is there a way to show the info without resetting the AirPods?

  • Have you tried forgetting the AirPods on the device Bluetooth settings, then resetting the AirPods as mentioned? Getting the info to show up is buggy for me as well, but it only takes a couple tries for it to show up for me. – JBallin Nov 8 at 22:40
  • Is iOS up to date on the device? – JBallin Nov 8 at 22:41
  • Have you made sure that the AirPods have the latest firmware updates? Quick google search pulled this up: howtogeek.com/409105/how-to-update-your-airpods-firmware – JBallin Nov 8 at 22:42
  • @JBallin The iOS version is 13.1.2 so it is near the latest version. Upgrading the firmware... I viewed the AirPods as consumer electronics, and it has been released for so long for this basic "info" feature so I wouldn't think I had to upgrade the firmware for this basic function to work – nopole Nov 10 at 6:09
  • Got it. I would consider contacting Apple, seems like something may be bad with the hardware. Have you experimented with other AirPods and/or iPhones? – JBallin Nov 10 at 7:51
1

Open your case lid with your AirPods inside and hold your case close to your device. Wait a few seconds to see the charge status of your AirPods with a charging case. It appears as:

enter image description here

If you don't see info, then just take one Airpod and put back in case. Wait for a while and then it will appear again as shown in the picture. You don't need to reset to get the information back on your iPhone.

  • "then just take one Airpod and put back in case. Wait for a while and then it will appear again as shown in the picture" Tried it a few times. Doesn't work. – nopole Nov 9 at 2:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .