2

I recently got a new MacBook Pro (2019 model). With this computer, if the displays are sleeping (I often have an external monitor attached via USB-C dock), they will wake up for a few seconds when a notification comes in, and then they go back into power-saving mode. My previous MBP (late 2013 model) did not have this problem. I call it a problem as the computer is in my bedroom, and the momentary flash of light is waking me up sometimes at night. How can I stop this from happening? (Both Macs are running 10.14.6)

6
  • 3
    Have you tried using Do Not Disturb during these hours?
    – fsb
    Nov 7, 2019 at 15:40
  • @fsb DND is not on - I will try that this evening. (Although that wasn't on on my previous MBP...)
    – Conrad
    Nov 7, 2019 at 15:58
  • 1
    You could turn off Power nap too
    – anki
    Nov 7, 2019 at 21:05
  • 1
    @ankii Power Nap isn't applicable here - the MBP is not asleep, but awake with screen savers on.
    – Conrad
    Nov 7, 2019 at 21:07
  • 1
    @fsb I checked the "Turn on Do Not Disturb: When the display is sleeping" option and that seems to have done the trick. If you'd like to answer this question I'll mark it as the answer.
    – Conrad
    Nov 8, 2019 at 20:44

1 Answer 1

2

You can turn on Do Not Disturb ("DND") mode to prevent distractions or notifications during specific timeframes.

Source:

Schedule Do Not Disturb

  1. On your Mac, choose Apple menu > System Preferences or open "System Preferences" directly from the icon.
  2. Click "Notifications".
  3. Select "Do Not Disturb" at the top of the sidebar.

You can stop notifications during a time period, when your Mac is in sleep (useful if you sleep near your Mac) by checking the "When the display is sleeping" box.

enter image description here

If you want to receive call notifications even when Do Not Disturb is on, select the call checkboxes.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .