it's a shame that the OS have degraded to this levels of breakage and bugs.

There's a way to stop accountsd from eating up all my CPU when I'm without internet access in a wireless connection for LAN only?

accountsd eating up all my cores

So there's any workaround for this? I don't even expect a fix from Apple anymore.

Many friends are ditching OS integrated internet accounts to avoid this issues, but I really don't want to go this path, only if it became my last resource.

  • Possible duplicate of Why is the accountsd process eating so much CPU?
    – anki
    Commented Nov 5, 2019 at 19:19
  • It's not eating up memory, and it's not duplicate from. It's an issue within the same software but not related on the thread. Since on the thread is vague and on macOS 10.10; we are five years later with a well defined issue in a specific condition, and not under normal usage like on the linked thread. Commented Nov 5, 2019 at 20:23
  • 1
    No, the only common denominator was really the connection without WAN access. I've double checked the answers on the linked thread and it seems to be Gmail related. In fact I do have a Gmail account added on Internet Accounts. But it's only for mail, some folks says about calendar specific. I can try removing the Gmail account completely and see what happens. Commented Nov 5, 2019 at 20:33
  • @ankii Mail was crashed LOL. Take a look at the picture. I'll double check and edit the question. Commented Nov 5, 2019 at 20:41
  • It seems to be stuck/ beachball. All I see is it being open in BG, and its high CPU usage
    – anki
    Commented Nov 5, 2019 at 20:44

3 Answers 3


After various attempts at disabling and logging out of iCloud accounts on the device, in the end a reset of Keychain fixed it:

Keychain Access -> Preferences -> Reset My Default Keychains

  • Thanks: this one (Keychain Access -> Preferences -> Reset My Default Keychains) worked for me. However, be aware that all passwords for mail accounts need to be re-entered. Commented Mar 9, 2020 at 19:48

What seemed to have fixed it for me is re-enabling mail access to spotlight:

System preferences -> Spotlight -> "Mail & messages"


After a lucky move and being able to contact Apple, I've sent some logs to the chief engineer of accountsd and on the release of macOS 10.15.4 this bug was solved.

So the fix would be upgrade to at least 10.15.4.

  • 5
    Still have the bug on 10.15.5
    – gagarine
    Commented Jun 16, 2020 at 13:36
  • Still have it on 10.15.7 Commented Sep 29, 2020 at 17:47
  • 1
    Ok, I just fixed this by signing out my Apple ID by going to SystemPreferences -> Apple ID. I don't have enough reputation to post this solution, but found it here: apple.stackexchange.com/questions/182059/… Commented Sep 29, 2020 at 18:22
  • @SandervandenOord the issue does not seems to be related. I've seen this link when this issue affected me and I didn't worked ou my case. So it's the same issue, but the origin of the issue may not be the same. Commented Sep 30, 2020 at 18:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .