3

I tried running tmutil and after waiting about 5 minutes it spit out this message

$ tmutil listbackups
tmutil: listbackups requires Full Disk Access privileges.
To allow this operation, select Full Disk Access in the Privacy
tab of the Security & Privacy preference pane, and add Terminal
to the list of applications which are allowed Full Disk Access.

My question is, can I just run it as root as in

$ sudo tmutil listbackups

Or do I have to give it Full Disk Access permissions? I'd prefer running as root as it's more temporary but I'm worried something might break (some permisisons get set incorrectly etc...) Of course I can give it permission and revoke it later. I'm sure curious, can I run as root instead?

1 Answer 1

3

Running the command as root does not give it the necessary permission to bypass the "Full Disk Access" prompt.

You will need to actively give it the "Full Disk Access" privilege as described in the message, you have cited. Afterwards you can take away the privilege to ensure it is a temporary thing.

1
  • how do you do this?
    – v3nt
    Oct 3, 2023 at 14:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .