4

I have the Oracle Instantclient installed (PHP needs it for the oci extension to work), the install directory is /opt/instantclient_19_3 and every time I log in after a reboot I get the following error messages which read translate to

libclntsh.dylib.18.1 cannot be opened because the developer can't be verified. libclntshcore.dylib.19.1 cannot be opened because the developer can't be verified

I had the same errors popup when using Terminal and Hyper but since I've allowed those apps full disk access everything works fine. Still, after logging in I get both error messages, so I assume something needs permissions but I can't figure it out. Any hints?

libclntsh.dylib.18.1

libclntshcore.dylib.19.1

3

This should do it!

System Preferences -> Security & Privacy -> Developer Tools

enter image description here

White-listing one-by-one

While launching your non-verified app keep your System Preferences -> Security & Privacy -> General open. You can whitelist executables and libraries along the way. They will pop up in the general tab.

A signing tool

https://github.com/mitchellh/gon

| improve this answer | |
  • Hyper, VS Code and Terminal are listed and checked. – mazedlx Nov 4 '19 at 7:58
  • @mazedlx Are they listen under Developer Tools? – Bjarte Brandt Nov 4 '19 at 9:45
  • Yes, they all are. – mazedlx Nov 4 '19 at 13:05
  • @mazedlx I have updated my answer. Whitelist one-by-one – Bjarte Brandt Nov 4 '19 at 14:44
  • The error only shows up after login. And all the „usual suspects“ are showing up in Developer Tools. – mazedlx Nov 6 '19 at 5:37
1

Found it!

The solution is to open the General tab in security and wait for the libs to show up and allow them there.enter image description here

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .