3

I managed to wrongly format my SSD into MBR (Master Boot Record), since then my Mac is stuck starting in Internet Recovery Mode over and over again and I also can't run the Terminal command for example (CMD+S) to erase the SSD by hand.

enter image description here

There would not be any problems to recover it with the Internet Recovery Mode, but as soon as I choose my WiFi network, it will run on an endless loop. Neither I see any progress bar or ETA for the recovery. The process looks like this:

enter image description here

I once did run it for 24 hours, but except that fans was very loud, there was no process at all. I also used a different WiFi to see if there was a change (which was not).

The only thing I'm able to do is pressing the 'Option' key to boot from my USB but this is not working as well. It look like this:

enter image description here

As soon as I select the "Install macOS Mojave", it will start again the Internet Recovery Mode and it will run on endless loop, again.

Could be the USB fault for it? But if so, why the Terminal is not working?

4
  • have you tried clicking on "macOS Base System" to see if that made a difference? Commented Nov 3, 2019 at 15:44
  • Sorry, I forgot to mention that but yes, I already tried it as well. Basically, I only formated the "Macintosh HD" partition wrongly, so idk if this partition is included?
    – ciubuc
    Commented Nov 3, 2019 at 15:58
  • Basically, discussions.apple.com/thread/8603775 the same issue is for me, unfortunately they could not help him though.
    – ciubuc
    Commented Nov 3, 2019 at 16:46
  • Exact same problem. Created several USB boots with several apps including manual w/ Terminal. Chose various erase methods (GUID, etc). Chose several OS installers (Catalina, Mojave). USB recognized, defaults to Internet recovery. Internet recovery runs for days (10 times). Reset PRAM. Tried CMD-R, OPT-CMD-R, SHIFT-OPT-CMD-R. Will not mount in Target mode. 2019 Macbook Air TrueTone. Ran before I erased the SSD (stupid). Factor: battery is shot, requires power supply to run.
    – Billbad
    Commented Sep 28, 2020 at 14:33

1 Answer 1

1

You can try installing Ubuntu (or any other Linux distro) onto a USB. Then, start a live session. Open GParted and reformat your iMac’s HDD or SSD to GUID. After that, try booting into recovery mode again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .