4

I have a Mac Mini (late 2014) with its stock internal drive and an external SSD via USB. The external drive has Sierra and this is what I always boot from. The internal is a clone of the external just for backup, cloned via SuperDuper.

According to https://support.apple.com/en-us/HT210190 I can update directly to Mojave on this Mac Mini. I downloaded the installer from the App Store and ran it to install on the external drive. It took about 25 minutes and gave a "success" message, prompting me to restart to finish. When I restarted, it booted from the internal drive instead. I went to the Startup Disk pref pane and made sure the external was selected and tried again. It booted again from the internal drive. Good thing I had it as a backup :)

In the Startup Disk pref pane, the external drive is selectable but it still shows as a Sierra boot. I can tell the install did write to the external drive but I suppose it didn't finish. I ran the installer again -- it only took a few minutes and again showed "success" and a restart prompt. Same result.

I cloned the working internal boot drive back to the previously-working external SSD. So in theory I would be back where I started, with the SSD running Sierra and being my boot drive. But it still won't boot into it and it still shows as a valid choice in the Startup Disk pref pane. I tried resetting the NVRAM but no luck. And holding option at boot does nothing -- yes, it's a wired keyboard ;)

Thoughts?

8
  • What exactly does "holding option at boot does nothing" mean? Nothing appears as a choice in the Startup Menu? You can choose the external drive, but the internal drive boots instead? Or, something else? It also would have been helpful to include the output from diskutil list for the configurations that do not boot properly. – David Anderson Nov 3 '19 at 6:47
  • @David Anderson No startup menu appears, it goes right to normal boot. Literally as if I'm not holding Option at all. – mistercoffee66 Nov 3 '19 at 16:20
  • @DavidAnderson diskutil output for the external in its current state (Sierra, won't boot) is/dev/disk2 (external, physical): #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *512.1 GB disk2 1: EFI EFI 209.7 MB disk2s1 2: Apple_HFS MySSD 511.8 GB disk2s2 – mistercoffee66 Nov 3 '19 at 16:30
  • Is the wired keyboard an Apple keyboard? The behavior you are describing would indicate the use of a Windows keyboard. Has holding down the option key ever worked in the past with this keyboard? – David Anderson Nov 3 '19 at 16:58
  • @DavidAnderson Yes, Apple wired keyboard and yes, option has usually worked. In fact, resetting NVRAM requires command-option and that worked. – mistercoffee66 Nov 3 '19 at 18:15
1

When upgrading from Sierra to High Sierra, the firmware on older Mac logic boards is also updated. This allows a Mac to boot the newer macOS versions (starting with High Sierra) from APFS container partitions. Sierra can not be installed to boot from a APFS container, but Sierra can recognize APFS and therefore allows the selection an APFS volume with Mojave as the startup disk. However, the firmware may not agree with the selection. Possible reasons for failure are given below.

  • The upgrade from Sierra to Mojave do not also update the firmware.
  • The firmware update did not occur because you used an external drive to upgrade macOS.

You could backup your important data to an external drive, then do a clean install of High Sierra to the internal drive. If High Sierra is not available, then select a newer version of macOS. Afterwards, you can do a clean install of Mojave to the external drive.

Update:

Back when High Sierra was first released, I remember many questions similar to your question were posted here a Ask Different. I believe the consensus was that the firmware can only be upgraded from the internal drive. The update is written to the EFI partition on the drive before the firmware is instructed to update itself. The firmware is not capable of reading the update file from a USB drive. The firmware is capable of reading the update file from the first internal drive (disk0).

3
  • Thank you @David Anderson. If this is the case, why does the external drive no longer boot when restored to Sierra? – mistercoffee66 Nov 3 '19 at 16:23
  • I should add that I'm reluctant to do a clean install on the only drive that's currently bootable. Looking at my other external drives to see if any are free to wipe and install a bootable OS... – mistercoffee66 Nov 3 '19 at 18:19
  • A different drive didn't change anything (see comments to OP) – mistercoffee66 Nov 3 '19 at 21:06
1

Just to close the loop --

Option at boot worked when I switched the keyboard to a different USB port. I can now boot into my external drive(s) but only via the boot menu, not by setting it Startup Disk pref pane. Not perfect but good enough and thankfully a simple solution.

2
  • Finding a solution can be difficult when you have more than one problem. So can I assume you can now boot Mojave on the external drive? – David Anderson Nov 4 '19 at 14:15
  • @DavidAnderson Yes, thank you for your help. I hope this last part helps anyone else w a 2014 Mac Mini to remind them that not all the USB ports are equally functional. Certainly muddied the waters for me. – mistercoffee66 Nov 4 '19 at 16:39
1

I have a similarish issue. 2013 Mac, running Catalina upgraded from High Sierra. I could actually boot to a external SSD then a install broke that (still not sure what happened). Through recovery i reinstalled to my old internal drive (which i thought was broken), all good.

Then attempt to recreate my external drive. I tried everything to create a bootable external SSD with no luck. Everytime i tried, i could start a install but it wouldn't complete, on reboot it just went back to the login page.

I could only reach Recovery if i disconnected the external drive. I've now tried partitioning the old drive to see if that works which it does! So i can create two bootables just on the same drive. Still can't create externally though.

What was the issue with the USB ports?

0

I had a similar experience with a Late 2013 iMac 27" with intel Core i5.

Edit: I was made aware that this sounds like I have this problem too. But I created this post because I was able to fix this issue. TLDR is "boot into safe mode" but I followed a long list of troubleshooting Steps before I got it to work, if you’d like you can go through what I did.

Background: I have a mechanical HDD built in. I had also upgraded to Catalina, but because of some bugs, I downgraded to Mojave. Along with that, for some improved performance, I created a bootable install of Mojave on a Crucial 500GB ssd inside of a USB-C enclosure, (and a USB-A to USB-C adapter from Monoprice) I started booting from that external drive and things were manageable for a while. I say manageable and not perfect because occasionally, after leaving my iMac unattended, I would come back to find my iMac rebooted into the internal HDD OS. I then simply rebooted to the external SSD.

However, since yesterday, I stopped being able to boot into the ssd install. It would always come back to the install on the internal HDD.

I tried the following steps:

  1. Plug external SSD into a different USB-A port on the iMac.
  2. Run First Aid on SSD from Disk Utility multiple times between attempts to boot from it.
  3. Plug the external SSD into my Belkin Thunderbolt 2 dock's USB-A port.
  4. Try a fresh, unused USB-C to USB-A adapter to connect SSD to iMac directly and via Belkin's Thunderbolt 2 dock.
  5. Test the ssd on MacBook-Pro with thunderbolt 3/USB-C ports. (MacBook Pro booted up from the external SSD just fine.)
  6. Tried to boot on iMac from SSD now(In case a successful boot changed some settings)
  7. Tried to hold down option while booting into iMac to get to the startup disc choice screen. But iMac refused to boot into that mode.
  8. Reset PRAM and NVRAM on iMac. Still no luck getting SSD to work.
  9. Used ⌘+R to boot into recovery mode. Got into recovery mode from the internal HDD and restored from previous time machine backup onto SSD. SSD was erased and Mojave was re-installed and/or restored. Still unable to boot from SSD.
  10. Rebooted in safe mode, still from the HDD.
  11. Tried to restart from ssd but rebooted into HDD in normal mode.
  12. Plugged the Apple bluetooth keyboard into the iMac via USB-A to lightning cable.
  13. Restarted and held down option. This time it finally worked and I see options to boot from: HDD or time machine. SSD was still not showing up. At that time, it was still plugged into the Belkin Thunderbolt dock.
  14. Unplug SSD and plugged it into the iMac USB-A port. The SSD finally showed up as an option to boot from!
  15. booted into SSD in safe mode first. Then restarted in normal mode. SUCCESS!
  16. I was asked for my iCloud password to start restoring all settings I suppose.
1
  • This doesn't read as an answer to the question, more as an "I'm having this problem too". If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. – Tetsujin Dec 25 '20 at 12:36
0

I had a similar issue with a Late 2012 iMac 27" with a (partially) broken fusion drive. So i wanted to install Catalina on external SSD because an internal hd replacement seemed quite complicated for this iMac model... I then ran into the same issues that the installation on the external ssd was initiated successfully, but upon first reboot, the external ssd was not detected and the system bootet to the internal drive.

I finally got this fixed by using a newer enclosure for my SSD drive. I first used a quite old USB3.0 enclosure and had already ordered a newer one for better performance and after switching the enclosure, the installation went through fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .