2

Screen Recording

Since I've updated to Catalina, the App Store, for me, cannot:

  1. Automatically find any new app updates
  2. Update an app when I try to do it manually.

When I click on 'updates', I see "No updates - all your apps are up to date" but when I search for one of my apps, it says "update". When I click on update, the progress circle shows and it goes to 100%, but then the "update" button re-appears.

I have a video to show but cannot work out how to attach it.

I have reset my pram, logged out and back in on iCloud, have deleted the various .plist files and have emptied my cache, yet have achieved nothing. Anybody having this same issue and have found a solution?

0
0

I ran into this problem in Big Sur (currently Public Beta).

I also noticed that App Store apps that I had on my system were showing up in my App Store account list as though they were available to download but not installed.

I tried various methods including deleting App Store caches and preferences files, deleting the keychain item (search in Keychain.app for appstored), and signing out and signing in to the App Store.

In my case, the problem was that Spotlight was no longer indexing /Applications for some reason, even though /Applications was not excluded from indexing.

I opened Terminal and ran:

sudo mdutil -a -i off

then

sudo mdutil -a -i on

And shortly afterward, the App Store showed available updates, and my installed apps were showing up as installed in the App Store as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .