1

I am asking for help on getting back into my MacBook Pro. I finally allowed a software update. I was a bit careless and didn't check what was updating. The account refuses my password, so I hold down command-R to boot in recovery mode.

I open a terminal and if I type:

diskutil APFS list

I get the following output (abbreviated):

Volume disk2s1 
---------------------
APFS Volume Disk (Role):   disk2s1 (No specific role)
Name:                      Mackintosh HD (Case-insensitive)
Mount Point:               Not Mounted
Capacity Consumed:         73577095168 B (73.6 GB)
Encrypted:                 ERROR -69808

Attempting to repair fails:

diskutil repairvolume disk2s1
Started file system repair on disk2s1 Macintosh HD
Repairing file system
Volume is already unmounted
Performing fsck_apfs -y -x /dev/rdisk2s1
error: mount_apfs exit status 73
File system check exit code is 78
Restoring the original state found as unmounted
Error: -69845: File system verify or repair failed
Underlying error: 78

Running fsck_apfs -n -d /dev/rdisk2s1 gives 
mount_apfs: mount: Input/output error
error: mount_apfs exit status 73

Any ideas how to recover the data?

  • Totally the same......... Have u fixed it later? – Yost Leon Nov 5 '19 at 2:57
  • Took it to the Genius Bar. They basically tried everything I tried and we ended up wiping the HD and installing again. :-( – Ivo Nov 6 '19 at 6:55
1

Even though you have now wiped the drive and are using your MacBook, I would strongly advise that you look at the SMART reports for your drive, especially if it is a traditional spinning HDD — mount: Input/output error suggests that your drive is failing.

For future reference, if your drive is failing, a tool like ddrescue will allow you to create a byte-for-byte copy of the readable data on the drive to another drive. The copy can then be inspected further to attempt data recovery without any risk of complete data loss due to the failing drive becoming completely inoperable.

| improve this answer | |
  • This was a file system error (related to encryption) and had nothing to do with the physical condition of the drive. SMART status and disk recovery has no effect here. – Allan Nov 15 '19 at 20:21
  • @Allan Assuming that APFS software-based encryption was being used: for diskutil apfs list to report Encrypted: ERROR -69808 and fsck to immediately report I/O error indicates an issue with the disk rather than the file system structures, no? If it was simply an issue with the APFS structures, fsck ought to at least report the status of the container superblock (which is never encrypted via software encryption), but it did not. – Jivan Pal Nov 15 '19 at 20:34
  • The only situation in which hardware encryption is used is when a T2 chip is present, which, for MacBook Pro's, is only since July 2018. – Jivan Pal Nov 15 '19 at 20:37
  • Two clues tell you what you need to know: 1) It says it's a file system error and 2) the OP says a wipe and reinstall fixed the issues. It's also highly unlikely (read as not impossible but it's pretty much not going to happen), APFS is for SSD's and Apple will not convert a spinning drive to APFS – Allan Nov 15 '19 at 20:38
  • @Allan Where does it say there's a file-system error? The source error being cascaded upwards to fsck and diskutil repairvolume is mount_apfs exit status 73, which results in fsck_apfs error 78 – Jivan Pal Nov 15 '19 at 20:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .