2

For some reason, contacts are just not syncing between my iPhone and Mac. When I add new contacts on my phone, they don't appear on iCloud. If they do, I might start troubleshooting the Mac.

I made sure that contacts is turned on under 'iCloud' on my phone. Low power mode is off. I'm currently connected to Wi-Fi. This has been going on for months unfortunately, and my contacts have never synced.

I'm on iOS 13 and macOS Catalina.

7
  • 1
    Is the contact in iCloud.com? If so, just wait for the second device to sync, if not, you should troubleshoot the first one.
    – anki
    Commented Oct 30, 2019 at 7:52
  • Huh, that's a really good point. I just checked and the new contacts are not synced on icloud.com. Not really sure what to do about that though, since contact syncing is turned on in the settings on my phone.
    – Hassan
    Commented Oct 30, 2019 at 18:23
  • Low power mode is off. I'm currently connected to Wi-Fi. This has been going on for months unfortunately, and my contacts have never synced.
    – Hassan
    Commented Oct 30, 2019 at 18:30
  • Add a contact on icloud.com and see if it appears on iphone..
    – anki
    Commented Nov 1, 2019 at 6:41
  • Just tried it. Strangely, yes the contact appears on my phone.
    – Hassan
    Commented Nov 1, 2019 at 19:26

0

You must log in to answer this question.

Browse other questions tagged .