3

I am trying to use Instruments on my laptop, but it seems that after updating to Catalina, it cannot access my Documents folder:

instruments

I have given access to the application, Full Disk Access, but it does not work (I even shut down the laptop and restarted it, and also checked for errors with Disk Utility).

preferences

Am I missing something?

4
  • What version of Xcode do you have?
    – Harcker
    Oct 29, 2019 at 16:09
  • @Harcker I am running Xcode Version 11.1 (11A1027)
    – senseiwa
    Oct 29, 2019 at 16:56
  • 1
    Try also: from Xcode ->Services ->Toggle Instrument Recording. Doing that added also Xcode to File And Folders in Privacy.
    – Yoan
    Oct 30, 2019 at 11:20
  • @Yoan adding Xcode did the trick! If you turn the comment in an answer I'll mark it.
    – senseiwa
    Oct 30, 2019 at 14:33

1 Answer 1

2

In Xcode you may start using Instruments with Xcode -> Services -> Toggle Instruments Recording.

This will trigger a chain of settings events inside OSX. The result can be verified by looking to File and Folders in Privacy tab (Xcode will be added also there).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .