4

I recently upgraded to Catalina on my Macbook Pro (2015) and have this bizarre issue:

If I open up the Python interpreter in Terminal, I am able to type normally except for when I press the delete key. When I do that, it inserts a space. This persists across all my Conda environments, as well as native Python installation.

I tried restarting, and plugging in an external keyboard, and the issue persists. The delete key seems to work normally on everything else I've tried. It also works on my shell (zsh) and on interpreters for other languages.

Has anyone else run into this issue?

  • If it's unique to "your python environment", then it's probably a bug in that. Talk to Conda. – benwiggy Oct 28 '19 at 20:24
  • 1
    This is also happening with the default python installation on my machine, not just the ones installed through Conda. And this is through terminal – Daniel Oct 28 '19 at 20:29
  • System installed python works fine here. Does it work correctly in a new user account? – benwiggy Oct 28 '19 at 22:20
  • Same problem. For me, running conda update conda a few times solved it. – Dominik Peters Mar 27 at 0:48
3

So after some further testing, it looked like it was an issue with only certain virtual environments that I was using that I had reconfigured by following the guide on anaconda:

https://www.anaconda.com/how-to-restore-anaconda-after-macos-catalina-update/

My system python had also been set to the conda one by default by this, which was why I was getting the issue.

I just ended up creating a new environment and reinstalling all my packages.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .