1

I am experiencing a weird behavior only affecting running apps in the Terminal (BASH).

When running wget someurl, it will timeout. If I run the same with sudo, it works.

Other apps have no connectivity issues to the same URLs (Chrome, Edge etc.).

The issue remains with and without firewall activated.

Example:

$ wget http://www.google.com
--2019-10-26 22:33:24--  http://www.google.com/
Resolving www.google.com (www.google.com)... 172.217.14.196
Connecting to www.google.com (www.google.com)|172.217.14.196|:80... 
connected.
HTTP request sent, awaiting response...

Nothing happens here, it'll time out. Google opens just fine in the browser. If I run wget with sudo, I get the HTTP response.

I ran the first aid option in disk util to repair file permissions on all volumes, no change.

Any idea?

Thanks!

1

After some more digging (using lsof), I found the culprit to be Sophos AntiVirus.

If you run into a similar issue, open Sophos preferences, disable Live Protection and anything enabled in Web Protection.

Then try running wget (or whatever was blocked) again.

Once that works, you can reset Sophos preferences to their defaults again and check if everything still works.

Looks like a bug in Sophos AntiVirus to me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .