5

I have attached a Microsoft Comfort Mouse 6000 to a USB-A port on my 2014 Mac Mini running macOS Catalina 10.15 (plus all supplemental updates current at time of posting).

The mouse works, but, when I open the Mouse System Preferences to change settings, it displays an image of an Apple Magic Mouse and mentions that my computer cannot connect to a Bluetooth mouse (see image below).

Many years ago, I tried an Apple Magic Mouse, but didn't like it, so switched back to my MS Mouse. Maybe I need to somehow uninstall some Magic Mouse drivers and/or settings.

I also cannot turn off Bluetooth, as I'm warned that I would lose my input devices, but my keyboard and my mouse are both USB-A, not Bluetooth. The only Bluetooth devices I own are my Mac Mini & my iPhone X. No devices are listed in my Bluetooth System Preferences.

How can I fix my Mouse System Preferences?

enter image description here

4
  • I had the same issue under Mojave with a Microsoft Comfort Mouse 4500. Another annoyance with these working but unrecognized-in-settings mice is that the "Ignore built-in trackpad when mouse or wireless trackpad is present" option in "Accessibility" > "Mouse & Trackpad" is ignored. Fortunately, an old USB Apple Mighty Mouse was on hand, which allowed disabling Bluetooth before plugging the Microsoft mouse back in, but a software solution would be very useful, or at least a list of (in)compatible mice. Aug 29, 2020 at 22:38
  • If your input devices aren't Bluetooth then you can safely turn it off.
    – Allan
    Aug 30, 2020 at 19:12
  • I have found out elsewhere how to turn off Bluetooth, but I still don’t have a usable Mouse preferences page.
    – XDR
    Aug 30, 2020 at 19:46
  • 1
    same issue here. bumping up the post to see if anyone knows the answer.
    – morpheus
    Mar 24, 2022 at 17:55

1 Answer 1

0

I have the same issue and I tried to connect a wireless mouse(either bluetooth or 5GHz usb adapter one), then let MacOS catch up that one so that the MacOS System Preference has the mouse settings, then set the general mouse settings there, remove the wireless mouse and plug the USB wire mouse back and the mouse settings are working for the wired one, at least most general mouse settings working fine for me. I just did this as I want to switch my mouse left/right click, and it works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .