2

Since upgrading to OS X Catalina, I started getting disk full notifications. After some looking, I discovered the cause is ~400 MB files in /private/var/tmp like this:

WiFiDiagnostics_2019-10-23_12.58.55.713_Mac OS X_MacBookPro15,4_19A602.tgz

Option-clicking on the wifi icon in the menu bar shows "Enable Wi-Fi Logging" (indicating it's disabled; if it's enabled, it shows "Disable…").

My findings so far:

  • It seems to happen more frequently on certain wifi networks than others.
  • It seems to happen more when Wireguard is running, and more when Wireguard is in use for a VPN. (It still happens with Wireguard quit, but not as much, it seems.)
  • At one point, it was creating a new file (~400mb) every 5 minutes.
  • I've tried enabling and disabling wifi logging, without luck.

I haven't been able to find anything on google. How do I stop the auto-generation of diagnostic logs?

Update: I've updated to 10.15.1, and also did an OS reinstall (not full disk wipe), and am still getting the log files appearing.

Update 2, Resolution? Short version: Somehow the command+option+control+shift+w key combo is triggering this.

Longer version: I did a full disk wipe and reinstall, then kept an eye on when this issue reappeared and installed my normal apps slowly. This file reappeared once I installed Karabiner to make my caps-lock key map to command+control+option+shift, which I use with Alfred App to make application keyboard shortcuts.

One of the shortcuts I made was command+control+option+shift+w to open iTerm. I'd noticed before that hitting this key combination made the screen flash white, but I couldn't find any information (at all, anywhere) nor any existing keyboard shortcuts indicating what that key combination would do. But sure enough, 5 minutes later, I had the log file show up.

My belief at this point is that that particular keyboard shortcut, command+option+control+shift+w, triggers something in OS X (possibly Catalina only; I don't have an older OS to test against) that starts the wifi logging.

I'm super interested to know how/why/where shift+control+option+command+w is actually being mapped. I've tried figuring out the com.apple.symbolichotkeys.plist file but without luck. I also tried that key combo on another Catalina install and it doesn't seem to do the same thing, so perhaps there's another app I have installed that configured that keyboard shortcut. But at this point I don't have the time to re-wipe the computer and set it up again to track it down.

  • It may look disabled in the UI, but if it isn't really disabled, as you have found, try Enabling it, wait a minute, then Disable it. I've found, sometimes, that by forcing a setting, I call it 'retoggling', macOS sometimes re-writes a settings .plist file that may have gone wonky. – IconDaemon Oct 23 at 22:31
  • @IconDaemon No luck, unfortunately. VPN seems to exacerbate it, but it might just be because I'm on the VPN most of the time. – brett_f Oct 24 at 20:21
  • I've removed the VPN and profile configs, turned wifi off and on, rebooted, and I'm still getting logs ever ~5 minutes. Fills up my drive in about a day. Nothing I do seems to have any impact. – brett_f Oct 29 at 17:31
  • Command-Option-Shift-Control-Period (.) is indicated by this question apple.stackexchange.com/questions/59917/… – ankii Nov 25 at 19:47
  • @ankii Thanks! I'd actually seen that key combo trigger the behaviour as well, after my last update. Looks like that's as close to an answer as we're going to get. I used Karabiner to make those specific key chords map to "escape" instead (just so they don't trigger that behaviour). – brett_f Nov 27 at 19:45

You must log in to answer this question.

Browse other questions tagged .