2

In previous macOS, when you used the Invert Colors feature (Preferences > Accessibility > Display > Invert Colors), all the colors on the screen would become inverted, including images, so a page like this one would look like this:

enter image description here

Note the image has blue tones and the rolling dice is black at the top

In recent macOS (I use Mojave), a feature called "Smart Invert" makes it now impossible to invert images on a webpage. The same page would now look like this:

enter image description here

Note how the dice and the image on the right have "normal" colors - and not the top left logo for some mysterious reason

How does one disable the so-called "Smart" part of the invert? It simply doesn't work for anyone trying to invert images, which a lot of people deal with very often, whether in the art world, historical research or any other photography-related fields. Besides, "Dark Mode" already does that.

How do I quickly invert images on my display?

  • I'm wondering this too, I'm sure it's just a plist option or something, it's frustrating no one else seems to have found a fix. – Patrick L Oct 22 at 3:53
2

I noticed the issue you were facing - it seems to happen on Safari. Have you thought about trying Firefox? It seems to not "Smart invert" on Firefox from what I can tell.

(I can't add a comment due to reputation).

| improve this answer | |
  • Welcome to Ask Different! Please refrain from adding comments in the Answer section, this is for answers to the questions. Once you have sufficient reputation you’ll be able to add comments and ask follow-up questions. To gain reputation, answer questions that are clear and concise. - From Review – fsb Jan 20 at 15:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .